summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilk Brewster2020-04-14 23:47:49 +0100
committerMilk Brewster2020-04-14 23:47:49 +0100
commit6df462d75ef8cd1f98450a3d596c7542a41e1fed (patch)
treecb20ea2c6a12352ffd41dc5de7f7fc0a4dd6e7d8
downloadaur-6df462d75ef8cd1f98450a3d596c7542a41e1fed.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD31
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..210b4c725f30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = catclock-aubio-git
+ pkgdesc = X clock, with cat mode, using aubio and pulseaudio to swing the tail to a beat
+ pkgver = r34.9de77d0
+ pkgrel = 1
+ url = https://github.com/BarkyTheDog/catclock
+ arch = x86_64
+ license = custom
+ makedepends = xorg-util-macros
+ makedepends = git
+ depends = libx11
+ depends = libxmu
+ depends = libxaw
+ depends = libxrender
+ depends = libxft
+ depends = libxkbfile
+ depends = openmotif
+ depends = pulseaudio
+ depends = aubio
+ provides = xorg-xclock
+ conflicts = xorg-xclock
+ source = catclock::git+http://github.com/BarkyTheDog/catclock#branch=master
+ md5sums = SKIP
+
+pkgname = catclock-aubio-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9837d088123a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Head_on_a_Stick <matthew.t.hoare at gmail dot com>
+
+pkgname=catclock-aubio-git
+_pkgname=catclock
+pkgdesc="X clock, with cat mode, using aubio and pulseaudio to swing the tail to a beat"
+pkgver=r34.9de77d0
+pkgrel=1
+arch=(x86_64)
+url='https://github.com/BarkyTheDog/catclock'
+license=('custom')
+depends=('libx11' 'libxmu' 'libxaw' 'libxrender' 'libxft' 'libxkbfile' 'openmotif' 'pulseaudio' 'aubio')
+makedepends=('xorg-util-macros' 'git')
+conflicts=('xorg-xclock')
+provides=('xorg-xclock')
+source=('catclock::git+http://github.com/BarkyTheDog/catclock#branch=master')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make WITH_TEMPO_TRACKER=1
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -D -m 755 xclock "$pkgdir/usr/bin/xclock"
+}