summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexis2024-04-02 03:03:18 -0400
committerAlexis2024-04-02 03:03:18 -0400
commit01f66ca8a14222b4f8601d10a1eee548b520eeec (patch)
tree76f5eaba4af36ef8a0b00ba7990b5c6d2d92821c
downloadaur-01f66ca8a14222b4f8601d10a1eee548b520eeec.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD42
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3188693582c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = catgirl-engine
+ pkgdesc = A game engine for cool moddability and procedurally generated data
+ pkgver = 0.12.30
+ pkgrel = 1
+ url = https://github.com/lexi-the-cute/catgirl-engine
+ arch = any
+ license = Zlib
+ makedepends = rust
+ makedepends = cargo-nightly
+ conflicts = catgirl-engine-git
+ source = catgirl-engine-0.12.30.tar.gz::https://static.crates.io/crates/catgirl-engine/catgirl-engine-0.12.30.crate
+ b2sums = SKIP
+
+pkgname = catgirl-engine
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..44c90a058ba7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.zst
+*.gz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40641c3a266a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Lexi <@alexis@foxgirl.land> (a fediverse address)
+
+pkgname=catgirl-engine
+pkgdesc="A game engine for cool moddability and procedurally generated data"
+arch=('any')
+url="https://github.com/lexi-the-cute/catgirl-engine"
+license=(Zlib)
+pkgver=0.12.30
+pkgrel=1
+conflicts=(catgirl-engine-git)
+source=("$pkgname-$pkgver.tar.gz::https://static.crates.io/crates/$pkgname/$pkgname-$pkgver.crate")
+b2sums=("SKIP")
+makedepends=(
+ "rust"
+ "cargo-nightly"
+)
+
+# Generated in accordance to https://wiki.archlinux.org/title/Rust_package_guidelines.
+# Might require further modification depending on the package involved.
+prepare() {
+ cd "$pkgname-$pkgver"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ export RUSTFLAGS="-L/usr/lib -lzstd"
+ export RUSTUP_TOOLCHAIN=nightly
+ export CARGO_TARGET_DIR=target
+ cd "$pkgname-$pkgver"
+ cargo build --frozen --release
+}
+
+check() {
+ export RUSTUP_TOOLCHAIN=nightly
+ cd "$pkgname-$pkgver"
+ cargo test --frozen
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
+} \ No newline at end of file