summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexis2024-04-02 04:03:51 -0400
committerAlexis2024-04-02 04:03:51 -0400
commit1abeec4b0b8975078fff48f74a6393179cf51cd7 (patch)
tree7a81e8dfc235af1401f499c633ad90b549e46a8c
parentefe5ae8f685e94443128f5496e647e2a009a101f (diff)
downloadaur-1abeec4b0b8975078fff48f74a6393179cf51cd7.tar.gz
fix desktop icon
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c6e36ddab90..465eeb46318d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = catgirl-engine-git
pkgdesc = A game engine for cool moddability and procedurally generated data
pkgver = v0.12.30.r20.g9e0dc34
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/lexi-the-cute/catgirl-engine
arch = any
license = Zlib
makedepends = git
makedepends = rust
makedepends = cargo-nightly
+ makedepends = sed
provides = catgirl-engine=v0.12.30
conflicts = catgirl-engine
source = git+https://github.com/lexi-the-cute/catgirl-engine.git
diff --git a/PKGBUILD b/PKGBUILD
index ebd615044623..89839b5eb76d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ arch=('any')
license=(Zlib)
url="https://github.com/lexi-the-cute/catgirl-engine"
pkgver=v0.12.30.r20.g9e0dc34
-pkgrel=1
+pkgrel=2
provides=("catgirl-engine=${pkgver%%.r*}")
conflicts=(catgirl-engine)
source=("git+https://github.com/lexi-the-cute/catgirl-engine.git")
@@ -16,6 +16,7 @@ makedepends=(
"git"
"rust"
"cargo-nightly"
+ "sed"
)
# Automatically updates pkgver variable
@@ -49,5 +50,10 @@ check() {
# Packages built files
package() {
cd "catgirl-engine"
+ sed -i "s/\${engine_path}/\/usr\/bin\/catgirl-engine/" client/assets/resources/catgirl-engine.desktop
+ mv client/assets/vanilla/texture/logo/logo.png client/assets/vanilla/texture/logo/catgirl-engine.png
+
+ install -Dm0755 -t "$pkgdir/usr/share/icons" "client/assets/vanilla/texture/logo/catgirl-engine.png"
+ install -Dm0755 -t "$pkgdir/usr/share/applications/" "client/assets/resources/catgirl-engine.desktop"
install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/catgirl-engine"
}