summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Marshall2018-04-09 14:22:21 -0400
committerJosh Marshall2018-04-09 14:22:21 -0400
commitc41104f4a09095c1237a0ec311e2be7430d4abf4 (patch)
tree5f9e22f94e450a3a51a586194ea2d10796b05d6d
parentd44999f1073d5a3c5ecc8512bdca0111bf356468 (diff)
downloadaur-c41104f4a09095c1237a0ec311e2be7430d4abf4.tar.gz
Fixing up some minor package considerations.
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7497b8347ee..63e4e79472fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cath-tools-git
- pkgdesc = Protein structure comparison tools such as SSAP and SNAP
- pkgver = 1
- pkgrel = 1
+ pkgdesc = Protein structure comparison tools such as SSAP and SNAP.
+ pkgver = v0.16.2.r20.g82fb9ac7
+ pkgrel = 2
url = http://orengogroup.info/software/
arch = i686
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = cath-tools-git
depends = gsl
provides = cath-tools
conflicts = cath-tools
- source = cath-tools::git+https://github.com/anadon/cath-tools
+ source = cath-tools-git::git+https://github.com/anadon/cath-tools
md5sums = SKIP
pkgname = cath-tools-git
diff --git a/.gitignore b/.gitignore
index 6e15e651603f..6a5590cce1b6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-cath-tool-git-1-1-x86_64.pkg.tar.xz
-cath-tools/
+*.pkg.tar.xz
+cath-tools-git/
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index 797a24b761e0..ff373d3a8609 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Josh Marshall <jrmarsha@mtu.edu>
pkgname=cath-tools-git
-pkgver=1
-pkgrel=1
-pkgdesc="Protein structure comparison tools such as SSAP and SNAP"
+pkgver=v0.16.2.r20.g82fb9ac7
+pkgrel=2
+pkgdesc="Protein structure comparison tools such as SSAP and SNAP."
arch=('i686' 'x86_64')
license=('GPL3')
url="http://orengogroup.info/software/"
@@ -11,22 +11,27 @@ depends=('gsl')
makedepends=('gsl' 'cmake' 'ninja' 'make' 'git')
provides=('cath-tools')
conflicts=('cath-tools')
-source=("cath-tools::git+https://github.com/anadon/cath-tools")
+source=("cath-tools-git::git+https://github.com/anadon/cath-tools")
md5sums=('SKIP')
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
- cd "$provides"
+ cd "$pkgname"
cmake -G Ninja -DCMAKE_BUILD_TYPE=RELEASE -D USE_STATIC_GSL:BOOL=FALSE .
ninja
}
check() {
- cd "$provides"
+ cd "$pkgname"
CATH_TOOLS_BIN_DIR=. prove -l -v perl/t
}
package() {
- cd "$provides"
+ cd "$pkgname"
#make install
#Install the executables
mkdir -p "$pkgdir/usr/bin"