summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-04-10 07:11:09 +0000
committerPellegrino Prevete2023-04-10 07:11:09 +0000
commit88bb8fd2693f7ba2b547168bd663f952df211edd (patch)
treeaffd030efaece12486c1aea4820e6fbda59c8ec0
downloadaur-88bb8fd2693f7ba2b547168bd663f952df211edd.tar.gz
initial build
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a66eb807e76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = catimporter
+ pkgdesc = Import a category (with its subcategories) across mediawiki instances.
+ pkgver = 1.0
+ pkgrel = 5
+ url = https://github.com/ferdi2005/catimporter
+ arch = any
+ license = MIT
+ depends = ruby-httparty
+ depends = ruby-addressable
+ depends = ruby-mediawiki_api
+ source = catimporter::git+https://github.com/ferdi2005/catimporter
+ sha256sums = SKIP
+
+pkgname = catimporter
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0df7dbfbd0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+
+pkgname="catimporter"
+pkgver=1.0
+pkgrel=5
+pkgdesc="Import a category (with its subcategories) across mediawiki instances."
+arch=('any')
+_github="https://github.com"
+_ns="ferdi2005"
+url="${_github}/${_ns}/${pkgname}"
+depends=("ruby-httparty"
+ "ruby-addressable"
+ "ruby-mediawiki_api")
+license=("MIT")
+_commit="e0860e75df541ab5dcde57a7ca27e4d09d513aac"
+source=("${pkgname}::git+${url}")
+sha256sums=("SKIP")
+
+package(){
+ install -Dm755 "${srcdir}/catimporter/process.rb" \
+ "${pkgdir}/usr/bin/catimporter"
+}