summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDidrole2023-07-05 12:22:41 +0200
committerDidrole2023-07-05 12:28:28 +0200
commitc0d4db59f05ad4883938b8ccc1ae49f0a3f73cb7 (patch)
tree4241563211b06eba02cd0a6532f51fff1d8506b6
downloadaur-c0d4db59f05ad4883938b8ccc1ae49f0a3f73cb7.tar.gz
Initial commit.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2670c84d3166
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cato-client-bin
+ pkgdesc = VPN client from Cato Networks to connect to the Cato Cloud.
+ pkgver = 5.1.0.14
+ pkgrel = 1
+ url = https://clientdownload.catonetworks.com/
+ arch = x86_64
+ license = custom
+ makedepends = libarchive
+ depends = glibc
+ depends = gcc-libs
+ depends = zlib
+ source = https://clientdownload.catonetworks.com/public/clients/cato-client-install.deb
+ sha256sums = 11c797f110e26bda2122b1d6367c4ae4599e0afd5bac0bf00794dbf999290b22
+
+pkgname = cato-client-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c059bb96ebe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Didrole <Didrole@gmail.com>
+
+pkgname=cato-client-bin
+pkgver=5.1.0.14
+pkgrel=1
+pkgdesc='VPN client from Cato Networks to connect to the Cato Cloud.'
+arch=('x86_64')
+url='https://clientdownload.catonetworks.com/'
+license=('custom')
+depends=('glibc' 'gcc-libs' 'zlib')
+makedepends=('libarchive')
+
+source=("https://clientdownload.catonetworks.com/public/clients/cato-client-install.deb")
+sha256sums=('11c797f110e26bda2122b1d6367c4ae4599e0afd5bac0bf00794dbf999290b22')
+
+package() {
+ bsdtar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}/"
+ mv "${pkgdir}/lib/systemd" "${pkgdir}/usr/lib/"
+ rmdir "${pkgdir}/lib/"
+ mv "${pkgdir}/usr/sbin/cato-clientd" "${pkgdir}/usr/bin/"
+ rmdir "${pkgdir}/usr/sbin/"
+ rmdir "${pkgdir}/usr/local/lib/"
+}