summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorghostx312023-01-12 19:14:00 +0530
committerghostx312023-01-12 19:14:00 +0530
commit72c643c4950ac88842319e424cf676c9aa30dda5 (patch)
tree744f43a0b0e8d0070fd9906eca3e0d3d2b94261a
downloadaur-72c643c4950ac88842319e424cf676c9aa30dda5.tar.gz
feat: add catppuccin cursors git package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8cb08691a0e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = catppuccin-cursors-git
+ pkgdesc = Soothing pastel mouse cursors
+ pkgver = 0.2.0.r0.g31a2848
+ pkgrel = 1
+ url = https://github.com/catppuccin/cursors
+ arch = any
+ license = GPL2
+ makedepends = inkscape
+ makedepends = xorg-xcursorgen
+ conflicts = catppuccin-cursors-mocha
+ conflicts = catppuccin-cursors-macchiato
+ conflicts = catppuccin-cursors-frappe
+ conflicts = catppuccin-cursors-latte
+ source = catppuccin-cursors::git+https://github.com/catppuccin/cursors.git
+ sha256sums = SKIP
+
+pkgname = catppuccin-cursors-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cacf7b7ac516
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: spookyintheam <spookyintheam@proton.me>
+
+_pkgname='catppuccin-cursors'
+pkgname=${_pkgname}-git
+pkgver=0.2.0.r0.g31a2848
+pkgrel=1
+pkgdesc="Soothing pastel mouse cursors"
+arch=('any')
+url="https://github.com/catppuccin/cursors"
+license=('GPL2')
+makedepends=('inkscape' 'xorg-xcursorgen')
+conflicts=("$_pkgname-mocha" "$_pkgname-macchiato" "$_pkgname-frappe" "$_pkgname-latte")
+source=("$_pkgname::git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/^.*v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make build
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make install DESTDIR="$pkgdir"
+}