summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTuhana GAYRETLÄ°2022-03-17 11:10:41 +0300
committerTuhana GAYRETLÄ°2022-03-17 11:10:41 +0300
commit8cf2e635ef7d5a4fe2e88396aaad31da21b72cfb (patch)
tree82d21bfce3912a8fff4d55d3888571da740537da
parent18ea2cab863f41ff667d799f526562bd10dcdb0d (diff)
downloadaur-8cf2e635ef7d5a4fe2e88396aaad31da21b72cfb.tar.gz
make 'actual' VCS package
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD26
-rw-r--r--catppuccin-grub-theme-git.install (renamed from catppuccin-grub-theme.install)8
3 files changed, 25 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76144001d622..2abbddc3d483 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = catppuccin-grub-theme-git
- pkgdesc = Catppuccin GRUB theme.
+ pkgdesc = Soothing pastel theme for GRUB2.
pkgver = r24.3f62cd4
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/catppuccin/grub
- install = catppuccin-grub-theme.install
+ install = catppuccin-grub-theme-git.install
arch = any
license = MIT
- source = https://github.com/catppuccin/grub/archive/3f62cd4174465631b40269a7c5631e5ee86dec45.zip
- sha256sums = 6f73b676cdc4bf11dbe38fa31f3981db4f5b8afd68f5fbf05154c8e27f4d7848
+ makedepends = git
+ source = catppuccin-grub-theme-git::git+https://github.com/catppuccin/grub.git
+ sha256sums = SKIP
pkgname = catppuccin-grub-theme-git
diff --git a/PKGBUILD b/PKGBUILD
index 987b9747abb0..f53d6b05ffd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,28 @@
# Maintainer: Tuhana GAYRETLÄ° <tuhana at tuta dot io>
pkgname=catppuccin-grub-theme-git
-_pkgname=catppuccin-grub-theme
-_theme=catppuccin
pkgver=r24.3f62cd4
-pkgrel=2
-pkgdesc="Catppuccin GRUB theme."
+pkgrel=3
+pkgdesc="Soothing pastel theme for GRUB2."
arch=("any")
url="https://github.com/catppuccin/grub"
license=("MIT")
-source=("https://github.com/catppuccin/grub/archive/3f62cd4174465631b40269a7c5631e5ee86dec45.zip")
-sha256sums=("6f73b676cdc4bf11dbe38fa31f3981db4f5b8afd68f5fbf05154c8e27f4d7848")
-install=$_pkgname.install
+makedepends=("git")
+source=("$pkgname::git+https://github.com/catppuccin/grub.git")
+sha256sums=("SKIP")
+install="$pkgname.install"
-package() {
- cd $srcdir/grub-*
+pkgver() {
+ cd $pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
- install -dm755 "$pkgdir/usr/share/grub/themes/$_theme"
- cp -r --no-preserve=ownership $_pkgname/* "$pkgdir/usr/share/grub/themes/$_theme"
+package() {
+ cd $pkgname
+ install -dm755 "$pkgdir/usr/share/grub/themes/${pkgname%-grub-theme-git}"
install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md
+
+ cp -r --no-preserve=ownership ${pkgname%-git}/* "$pkgdir/usr/share/grub/themes/${pkgname%-grub-theme-git}"
}
diff --git a/catppuccin-grub-theme.install b/catppuccin-grub-theme-git.install
index 6bda8268c1aa..6b6ad2ec32c3 100644
--- a/catppuccin-grub-theme.install
+++ b/catppuccin-grub-theme-git.install
@@ -4,13 +4,13 @@ colorize
post_install() {
sed -ie 's,.*GRUB_THEME=.*,GRUB_THEME="/usr/share/grub/themes/catppuccin/theme.txt",' /etc/default/grub
- msg "Installed Catppuccin GRUB theme."
- msg2 "Run 'grub-mkconfig -o /boot/grub/grub.cfg' to apply the theme."
+ msg "Installed Catppuccin GRUB2 theme."
+ msg2 "Run 'grub-mkconfig -o /boot/grub/grub.cfg' as root to apply the theme."
}
post_remove() {
sed -ie 's,.*GRUB_THEME=.*,#GRUB_THEME="/path/to/gfxtheme",' /etc/default/grub
- warning "Removed Catppuccin GRUB theme."
- msg2 "Run 'grub-mkconfig -o /boot/grub/grub.cfg' to unapply the theme."
+ warning "Uninstalled Catppuccin GRUB2 theme."
+ msg2 "Run 'grub-mkconfig -o /boot/grub/grub.cfg' as root to disable the theme."
}