summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-08-07 01:51:51 -0500
committerLuis Martinez2022-08-07 01:51:51 -0500
commita317c146e25845dc0b69959c39bc28671bd72af9 (patch)
tree4dea35589d8fb94d1ad0ec545cf214ac85a068ac
parentc4078616a27df55071ea3a86e2642f4b470619bd (diff)
downloadaur-a317c146e25845dc0b69959c39bc28671bd72af9.tar.gz
packaging update
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD67
2 files changed, 36 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4fb1a3f0dcd..7bf3c37e302c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,26 @@
pkgbase = catppuccin-grub-theme-git
pkgdesc = Soothing pastel theme for GRUB2
pkgver = r25.4f6ac65
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/catppuccin/grub
arch = any
license = MIT
makedepends = git
- source = git+https://github.com/catppuccin/grub.git
+ source = catppuccin-grub-theme::git+https://github.com/catppuccin/grub
sha256sums = SKIP
pkgname = catppuccin-frappe-grub-theme-git
- pkgdesc = Soothing pastel theme for GRUB2 - frappe color scheme
+ pkgdesc = Soothing pastel theme for GRUB2 -- Frappe colorscheme
install = catppuccin-frappe-grub-theme-git.install
pkgname = catppuccin-latte-grub-theme-git
- pkgdesc = Soothing pastel theme for GRUB2 - latte color scheme
+ pkgdesc = Soothing pastel theme for GRUB2 -- Latte colorscheme
install = catppuccin-latte-grub-theme-git.install
pkgname = catppuccin-macchiato-grub-theme-git
- pkgdesc = Soothing pastel theme for GRUB2 - macchiato color scheme
+ pkgdesc = Soothing pastel theme for GRUB2 -- Macchiato colorscheme
install = catppuccin-macchiato-grub-theme-git.install
pkgname = catppuccin-mocha-grub-theme-git
- pkgdesc = Soothing pastel theme for GRUB2 - mocha color scheme
+ pkgdesc = Soothing pastel theme for GRUB2 -- Mocha colorscheme
install = catppuccin-mocha-grub-theme-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 81b76ee77ba0..644a202375c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,63 +1,56 @@
-# Maintainer: Tuhana GAYRETLÄ° <tuhana at cok dot gay>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Tuhana GAYRETLÄ° <tuhana at cok dot gay>
# shellcheck disable=SC2034,SC2148,SC2164,SC2154,SC2128
pkgname=(
catppuccin-frappe-grub-theme-git
catppuccin-latte-grub-theme-git
catppuccin-macchiato-grub-theme-git
- catppuccin-mocha-grub-theme-git
-)
+ catppuccin-mocha-grub-theme-git)
pkgbase=catppuccin-grub-theme-git
+_pkg="${pkgbase%-git}"
pkgver=r25.4f6ac65
-pkgrel=1
+pkgrel=2
pkgdesc='Soothing pastel theme for GRUB2'
-arch=(any)
+arch=('any')
url='https://github.com/catppuccin/grub'
-license=(MIT)
-makedepends=(git)
-source=("git+$url.git")
-sha256sums=(SKIP)
+license=('MIT')
+makedepends=('git')
+source=("$_pkg::git+$url")
+sha256sums=('SKIP')
+
+_package() {
+ cd "$_pkg/src"
+ find "$1" \
+ -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/grub/themes/{}" \;
+ install -Dm644 ../LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+}
package_catppuccin-frappe-grub-theme-git() {
- pkgdesc+=' - frappe color scheme'
- install=$pkgname.install
-
- cd "$srcdir/grub"
+ pkgdesc+=' -- Frappe colorscheme'
+ install=$pkgname.install
- install -d "$pkgdir/usr/share/grub/themes"
- cp -r "src/${pkgname%-git}" "$pkgdir/usr/share/grub/themes/${pkgname%-grub-theme-git}"
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+ _package catppuccin-frappe-grub-theme
}
package_catppuccin-latte-grub-theme-git() {
- pkgdesc+=' - latte color scheme'
- install=$pkgname.install
-
- cd "$srcdir/grub"
+ pkgdesc+=' -- Latte colorscheme'
+ install=$pkgname.install
- install -d "$pkgdir/usr/share/grub/themes"
- cp -r "src/${pkgname%-git}" "$pkgdir/usr/share/grub/themes/${pkgname%-grub-theme-git}"
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+ _package catppuccin-latte-grub-theme
}
package_catppuccin-macchiato-grub-theme-git() {
- pkgdesc+=' - macchiato color scheme'
- install=$pkgname.install
+ pkgdesc+=' -- Macchiato colorscheme'
+ install=$pkgname.install
- cd "$srcdir/grub"
-
- install -d "$pkgdir/usr/share/grub/themes"
- cp -r "src/${pkgname%-git}" "$pkgdir/usr/share/grub/themes/${pkgname%-grub-theme-git}"
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+ _package catppuccin-macchiato-grub-theme
}
package_catppuccin-mocha-grub-theme-git() {
- pkgdesc+=' - mocha color scheme'
- install=$pkgname.install
-
- cd "$srcdir/grub"
+ pkgdesc+=' -- Mocha colorscheme'
+ install=$pkgname.install
- install -d "$pkgdir/usr/share/grub/themes"
- cp -r "src/${pkgname%-git}" "$pkgdir/usr/share/grub/themes/${pkgname%-grub-theme-git}"
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+ _package catppuccin-mocha-grub-theme
}