summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTuhana GAYRETLÄ°2022-02-04 22:07:39 +0300
committerTuhana GAYRETLÄ°2022-02-04 22:07:39 +0300
commitbf3dc0df228a6c25e210b065793747f2516e424b (patch)
tree139fa70fdce0c19bf3816eb95ba874c5ed7b0b2e
downloadaur-bf3dc0df228a6c25e210b065793747f2516e424b.tar.gz
initial release
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
-rw-r--r--catppuccin-grub-theme.install12
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5bf051cc0e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = catppuccin-grub-theme-git
+ pkgdesc = Catppuccin GRUB2 theme.
+ pkgver = r14.9e5ade4
+ pkgrel = 1
+ url = https://github.com/catppuccin/grub
+ install = catppuccin-grub-theme.install
+ arch = any
+ license = MIT
+ source = https://github.com/catppuccin/grub/archive/9e5ade440a5506691f5afaa4b24aaba4e6c9d434.zip
+ sha256sums = 84f4d19e111b192efa733975d9f22bd70d1a99b62c60d8073d8ab5228cc0b4d8
+
+pkgname = catppuccin-grub-theme-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a9afd7645a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Tuhana GAYRETLÄ° <tuhana at tuta dot io>
+
+pkgname=catppuccin-grub-theme-git
+_pkgname=catppuccin-grub-theme
+_theme=catppuccin
+pkgver=r14.9e5ade4
+pkgrel=1
+pkgdesc="Catppuccin GRUB2 theme."
+arch=("any")
+url="https://github.com/catppuccin/grub"
+license=("MIT")
+source=("https://github.com/catppuccin/grub/archive/9e5ade440a5506691f5afaa4b24aaba4e6c9d434.zip")
+sha256sums=("84f4d19e111b192efa733975d9f22bd70d1a99b62c60d8073d8ab5228cc0b4d8")
+install=$_pkgname.install
+
+package() {
+ cd $srcdir/grub-*
+
+ install -dm755 "$pkgdir/usr/share/grub/themes/$_theme"
+ cp -r --no-preserve=ownership $_pkgname/* "$pkgdir/usr/share/grub/themes/$_theme"
+
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md
+} \ No newline at end of file
diff --git a/catppuccin-grub-theme.install b/catppuccin-grub-theme.install
new file mode 100644
index 000000000000..b81eaa7c0757
--- /dev/null
+++ b/catppuccin-grub-theme.install
@@ -0,0 +1,12 @@
+. /usr/share/makepkg/util/message.sh
+colorize
+
+post_install() {
+ sed -i -e 's,.*GRUB_THEME=.*,GRUB_THEME="/usr/share/grub/themes/catppuccin/theme.txt",' /etc/default/grub
+ msg "Catppuccin theme set as default! Run 'grub-mkconfig -o /boot/grub/grub.cfg' to apply theme."
+}
+
+post_remove() {
+ sed -i -e 's,.*GRUB_THEME=.*,#GRUB_THEME="/path/to/gfxtheme",' /etc/default/grub
+ warning "Removed Catppuccin GRUB theme! Run 'grub-mkconfig -o /boot/grub/grub.cfg' to deactivate theme."
+}