summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Nader2021-07-28 13:41:03 +0900
committerJason Nader2021-07-28 13:41:03 +0900
commit2bf3b9f10635aaaa8d69c065e7a78567daa2231b (patch)
treec16cae917479efd37e9acc10acb997b56f4486a5
downloadaur-2bf3b9f10635aaaa8d69c065e7a78567daa2231b.tar.gz
First commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..632be82ce8dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = catt-git
+ pkgdesc = Cast All The Things - Send videos from many, many online sources to your Chromecast.
+ pkgver = 0.12.1.r7.g0519e00
+ pkgrel = 1
+ url = https://github.com/skorokithakis/catt
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-click
+ depends = python-ifaddr
+ depends = python-netifaces
+ depends = python-pychromecast>=7.5.0
+ depends = python-requests
+ depends = youtube-dl>=2020.06.06
+ provides = catt
+ conflicts = catt
+ source = catt::git+https://github.com/skorokithakis/catt.git
+ sha256sums = SKIP
+
+pkgname = catt-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..edc2abecad45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+pkgname='catt-git'
+_pkgname=catt
+pkgver=0.12.1.r7.g0519e00
+pkgrel=1
+pkgdesc='Cast All The Things - Send videos from many, many online sources to your Chromecast.'
+arch=('any')
+url="https://github.com/skorokithakis/catt"
+license=('BSD')
+depends=(
+ 'python'
+ 'python-click'
+ 'python-ifaddr'
+ 'python-netifaces'
+ 'python-pychromecast>=7.5.0'
+ 'python-requests'
+ 'youtube-dl>=2020.06.06')
+makedepends=('python-setuptools')
+source=("${pkgname%-*}::git+https://github.com/skorokithakis/catt.git")
+sha256sums=('SKIP')
+provides=("catt")
+conflicts=("catt")
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm644 README.rst "${pkgdir}"/usr/share/doc/"${pkgname}"/README.rst
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+ python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+}