summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergio Correia2018-02-23 14:27:57 -0500
committerSergio Correia2018-02-23 14:27:57 -0500
commit554b0b9d9b28f3f071abe53fd21e25373dba4d4d (patch)
treecd280f90c1628b8cd614109c2474df7970bb2b6b
downloadaur-554b0b9d9b28f3f071abe53fd21e25373dba4d4d.tar.gz
cAURalho initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef554a6cc1fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cauralho-git
+ pkgdesc = A small tool to help with updating AUR packages installed in the system.
+ pkgver = r2.18ba2bb
+ pkgrel = 1
+ url = https://github.com/qrwteyrutiyoup/cauralho
+ arch = any
+ license = Apache
+ depends = dialog
+ depends = curl
+ depends = jq
+ depends = bash>=4.0.0
+ backup = etc/cauralho.conf
+ source = cauralho::git+https://github.com/qrwteyrutiyoup/cauralho.git
+ md5sums = SKIP
+
+pkgname = cauralho-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e57ea9050b3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Sergio Correia <sergio@correia.cc>
+
+pkgname=cauralho-git
+_pkgname=cauralho
+pkgver=r2.18ba2bb
+pkgrel=1
+pkgdesc="A small tool to help with updating AUR packages installed in the system."
+arch=("any")
+url="https://github.com/qrwteyrutiyoup/cauralho"
+license=("Apache")
+depends=(dialog curl jq 'bash>=4.0.0')
+source=("${_pkgname}"::git+https://github.com/qrwteyrutiyoup/cauralho.git)
+md5sums=('SKIP')
+backup=('etc/cauralho.conf')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_pkgname}"
+
+ install -Dm 755 "${srcdir}/${_pkgname}/cauralho" "${pkgdir}/usr/bin/cauralho"
+ install -Dm 644 "${srcdir}/${_pkgname}/cauralho.conf.sample" "${pkgdir}/etc/cauralho.conf"
+ install -Dm 644 "${srcdir}/${_pkgname}/cauralho.conf.sample" "${pkgdir}/etc/cauralho.conf.sample"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: