summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPQCraft2022-11-26 21:58:28 -0500
committerPQCraft2022-11-26 21:58:28 -0500
commitedacf7e1723e7384954a738c346b9619a5fa46ac (patch)
tree9a4d9cbc57928abe4b57ccdde331bbb6e0ebf786
downloadaur-edacf7e1723e7384954a738c346b9619a5fa46ac.tar.gz
0.5.1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD30
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01bcd7f02526
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = cavecube-sdl2-bin
+ pkgdesc = An in-development Minecraft/Infiniminer clone
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = https://github.com/PQCraft/CaveCube
+ arch = x86_64
+ arch = i686
+ license = Boost
+ depends = glibc
+ provides = cavecube
+ conflicts = cavecube
+ conflicts = cavecube-bin
+ conflicts = cavecube-sdl2
+ source = cavecube-sdl2-bin_data_0.5.1-1.zip::https://github.com/PQCraft/CaveCube/releases/download/0.5.1/cavecube_data.zip
+ sha256sums = SKIP
+ source_x86_64 = cavecube-sdl2-bin_game_sdl2_0.5.1-1.tar.gz::https://github.com/PQCraft/CaveCube/releases/download/0.5.1/cavecube_game_sdl2_linux_x86_64.tar.gz
+ sha256sums_x86_64 = SKIP
+ source_i686 = cavecube-sdl2-bin_game_sdl2_0.5.1-1.tar.gz::https://github.com/PQCraft/CaveCube/releases/download/0.5.1/cavecube_game_sdl2_linux_i686.tar.gz
+ sha256sums_i686 = SKIP
+
+pkgname = cavecube-sdl2-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9148f31d30b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: PQCraft <0456523@gmail.com>
+
+pkgname=cavecube-sdl2-bin
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="An in-development Minecraft/Infiniminer clone"
+arch=(x86_64 i686)
+url="https://github.com/PQCraft/CaveCube"
+license=(Boost)
+depends=(glibc)
+provides=(cavecube)
+conflicts=(cavecube cavecube-bin cavecube-sdl2)
+source=("${pkgname}_data_${pkgver}-${pkgrel}.zip::https://github.com/PQCraft/CaveCube/releases/download/${pkgver}/cavecube_data.zip")
+source_x86_64=("${pkgname}_game_sdl2_${pkgver}-${pkgrel}.tar.gz::https://github.com/PQCraft/CaveCube/releases/download/${pkgver}/cavecube_game_sdl2_linux_x86_64.tar.gz")
+source_i686=("${pkgname}_game_sdl2_${pkgver}-${pkgrel}.tar.gz::https://github.com/PQCraft/CaveCube/releases/download/${pkgver}/cavecube_game_sdl2_linux_i686.tar.gz")
+sha256sums=('SKIP')
+sha256sums_x86_64=('SKIP')
+sha256sums_i686=('SKIP')
+
+package() {
+ cd "${srcdir}"
+ find cavecube extras/ resources/ -not -path "extras/icon/*" -type f -exec install -Dm 755 "{}" "${pkgdir}/opt/CaveCube/{}" \;
+ cd extras/icon/
+ find hicolor/ -type f -exec install -Dm 755 "{}" "${pkgdir}/usr/share/icons/{}" \;
+ cd ../../
+ mkdir -p "${pkgdir}/usr/bin/"
+ ln -sf "/opt/CaveCube/cavecube" "${pkgdir}/usr/bin/cavecube"
+ mkdir -p "${pkgdir}/usr/share/applications/"
+ ln -sf "/opt/CaveCube/extras/cavecube.desktop" "${pkgdir}/usr/share/applications/cavecube.desktop"
+}