summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2019-08-30 11:01:09 +0200
committerFrederic Bezies2019-08-30 11:01:09 +0200
commit6a57b5f203c1162c9a34612827347c49f1865f86 (patch)
tree37d9bb2bcd71bb2e7008b7148b5b1aaaf30f009b
downloadaur-6a57b5f203c1162c9a34612827347c49f1865f86.tar.gz
initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD42
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3463c61de8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = cawbird-git
+ pkgdesc = A fork of the Corebird GTK Twitter client that continues to work with Twitter
+ pkgver = v1.0.r6.g4c4948ad
+ pkgrel = 1
+ url = https://github.com/ibboard/cawbird/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = vala
+ makedepends = git
+ makedepends = meson
+ makedepends = intltool
+ depends = gtk3
+ depends = libgee
+ depends = sqlite3
+ depends = gst-plugins-good
+ depends = gst-plugins-bad
+ depends = gst-libav
+ depends = gspell
+ optdepends = noto-fonts-emoji: Emoji support
+ provides = corebird
+ conflicts = corebird
+ conflicts = corebird-git
+ conflicts = corebird-non-streaming-git
+ source = cawbird-git::git+https://github.com/IBBoard/cawbird.git
+ sha1sums = SKIP
+
+pkgname = cawbird-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99def2eba407
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com >
+# Based on corebird-non-streaming-git PKGBUILD
+
+pkgname=cawbird-git
+_pkgname=cawbird
+pkgver=v1.0.r6.g4c4948ad
+pkgrel=1
+pkgdesc="A fork of the Corebird GTK Twitter client that continues to work with Twitter "
+arch=('i686' 'x86_64')
+license=('GPL')
+url="https://github.com/ibboard/cawbird/"
+depends=('gtk3'
+ 'libgee'
+ 'sqlite3'
+ 'gst-plugins-good'
+ 'gst-plugins-bad'
+ 'gst-libav'
+ 'gspell')
+optdepends=('noto-fonts-emoji: Emoji support')
+makedepends=('vala' 'git' 'meson' 'intltool')
+provides=('corebird')
+conflicts=('corebird' 'corebird-git' 'corebird-non-streaming-git')
+source=("${pkgname}::git+https://github.com/IBBoard/cawbird.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd ${pkgname}
+
+ meson builddir --prefix=/usr -D VIDEO=yes -D SPELLCHECK=yes
+ ninja -C builddir
+}
+
+package() {
+ cd ${pkgname}
+
+ DESTDIR="${pkgdir}" ninja -C builddir install
+}