summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorasm0dey2019-06-05 21:01:05 +0300
committerasm0dey2019-06-05 21:01:05 +0300
commitec49720b1f67e03fdc211667995d38f3389ac3dc (patch)
tree51427aabb7bdfda81aaedff9c04fa32fb70298fc
downloadaur-ec49720b1f67e03fdc211667995d38f3389ac3dc.tar.gz
Initial
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore52
-rw-r--r--PKGBUILD27
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1be3ec690140
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cb
+ pkgdesc = Find files with SQL-like queries
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/yaa110/cb
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ depends = gcc-libs
+ provides = cb
+ conflicts = cb-git
+ conflicts = cb-bin
+ source = 0.1.0.tar.gz::https://github.com/yaa110/cb/archive/0.1.0.tar.gz
+ sha512sums = 7cd81941d8313d4c195c5104e16c2e61c4cef654cdacef7ffec112690f53c7e937708da8456755e4926ae38526648a4a097d96398e8be54f66834fafc09a20e1
+
+pkgname = cb
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..29cc57d4bd61
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,52 @@
+
+# Created by https://www.gitignore.io/api/vim,visualstudiocode,archlinuxpackages
+# Edit at https://www.gitignore.io/?templates=vim,visualstudiocode,archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+### Vim ###
+# Swap
+[._]*.s[a-v][a-z]
+[._]*.sw[a-p]
+[._]s[a-rt-v][a-z]
+[._]ss[a-gi-z]
+[._]sw[a-p]
+
+# Session
+Session.vim
+
+# Temporary
+.netrwhist
+*~
+# Auto-generated tag files
+tags
+# Persistent undo
+[._]*.un~
+
+### VisualStudioCode ###
+.vscode/*
+!.vscode/settings.json
+!.vscode/tasks.json
+!.vscode/launch.json
+!.vscode/extensions.json
+
+### VisualStudioCode Patch ###
+# Ignore all local history of files
+.history
+
+# End of https://www.gitignore.io/api/vim,visualstudiocode,archlinuxpackages
+LICENSE*
+cb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1995d956b958
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: asm0dey <pavel.finkelshtein@gmail.com>
+
+pkgname=cb
+pkgver=0.1.0
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://github.com/yaa110/cb"
+license=("MIT")
+
+pkgdesc='Find files with SQL-like queries'
+
+source=("$pkgver.tar.gz::https://github.com/yaa110/$pkgname/archive/$pkgver.tar.gz")
+sha512sums=('7cd81941d8313d4c195c5104e16c2e61c4cef654cdacef7ffec112690f53c7e937708da8456755e4926ae38526648a4a097d96398e8be54f66834fafc09a20e1')
+makedepends=('rust')
+depends=('gcc-libs')
+conflicts=('cb-git' 'cb-bin')
+provides=('cb')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ install -Dm755 "$pkgname-$pkgver/target/release/cli" "$pkgdir/usr/bin/cb"
+ install -Dm644 "$pkgname-$pkgver/LICENSE-MIT" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}