summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Hentschel (hpmachining)2023-07-20 17:35:05 -0400
committerPaul Hentschel (hpmachining)2023-07-20 17:35:05 -0400
commit1724c92f2fa2c1662f88fcdda8b8c08d1c1879c3 (patch)
tree06e23740c7b55d546844f7006e659fc1811272ec
parentb55a73bcd4a3d5667639583f0ee53d3efba146fa (diff)
downloadaur-1724c92f2fa2c1662f88fcdda8b8c08d1c1879c3.tar.gz
Removed patches because of upstream fixes.
-rw-r--r--.SRCINFO7
-rw-r--r--0002_include_cstdint.patch11
-rw-r--r--0003_include_cstdint.patch13
-rw-r--r--PKGBUILD11
4 files changed, 5 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c64b9e6bf3d6..b1b0e7ff6ae3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cbang-git
pkgdesc = A library of cross-platform C++ utilities
- pkgver = r1511.ebab9fae
+ pkgver = r1519.58d2cb5c
pkgrel = 1
url = https://github.com/CauldronDevelopmentLLC/cbang
arch = x86_64
@@ -22,11 +22,8 @@ pkgbase = cbang-git
conflicts = cbang
source = git+https://github.com/CauldronDevelopmentLLC/cbang.git
source = 0001_v8_sandbox_enable.patch
- source = 0002_include_cstdint.patch
- source = 0003_include_cstdint.patch
sha256sums = SKIP
sha256sums = 75eff0bcd04293990f8dfb0771562356ccac2a7f40a06df0c0ba515fcdf4126a
- sha256sums = 0137c007c7596cbd9d9f7194cd6e1aaf11819489c815c57b29b9873523d25cd7
- sha256sums = 170101a781c105ed83225bfd0387348560d2dd89eede72de45fee60a6ba1a51a
+ sha256sums = 28f6efa9b9e85a85262478ef5c85414235768b19fcc2295504cc98b758075281
pkgname = cbang-git
diff --git a/0002_include_cstdint.patch b/0002_include_cstdint.patch
deleted file mode 100644
index 58cf1ec48887..000000000000
--- a/0002_include_cstdint.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ruN a/src/cbang/openssl/BigNum.h b/src/cbang/openssl/BigNum.h
---- a/src/cbang/openssl/BigNum.h 2023-05-08 16:23:34.979999959 -0400
-+++ b/src/cbang/openssl/BigNum.h 2023-05-08 16:24:14.376666623 -0400
-@@ -32,6 +32,7 @@
-
- #pragma once
-
-+#include <cstdint>
- #include <string>
-
- typedef struct bignum_st BIGNUM;
diff --git a/0003_include_cstdint.patch b/0003_include_cstdint.patch
deleted file mode 100644
index 3c0a82008291..000000000000
--- a/0003_include_cstdint.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/cbang/util/BIP39Words.h b/src/cbang/util/BIP39Words.h
-index f5afca1c..c4c2afe3 100644
---- a/src/cbang/util/BIP39Words.h
-+++ b/src/cbang/util/BIP39Words.h
-@@ -33,7 +33,7 @@
- #pragma once
-
- #include <string>
--
-+#include <cstdint>
-
- namespace cb {
- class BIP39Words {
diff --git a/PKGBUILD b/PKGBUILD
index 83d516c5d8ee..4f6b201224e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: greyltc
pkgname=cbang-git
-pkgver=r1511.ebab9fae
+pkgver=r1519.58d2cb5c
pkgrel=1
pkgdesc="A library of cross-platform C++ utilities"
arch=('x86_64')
@@ -32,13 +32,10 @@ optdepends=(
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
source=("git+https://github.com/CauldronDevelopmentLLC/cbang.git"
- "0001_v8_sandbox_enable.patch"
- "0002_include_cstdint.patch"
- "0003_include_cstdint.patch")
+ "0001_v8_sandbox_enable.patch")
sha256sums=('SKIP'
'75eff0bcd04293990f8dfb0771562356ccac2a7f40a06df0c0ba515fcdf4126a'
- '0137c007c7596cbd9d9f7194cd6e1aaf11819489c815c57b29b9873523d25cd7'
- '170101a781c105ed83225bfd0387348560d2dd89eede72de45fee60a6ba1a51a')
+ '28f6efa9b9e85a85262478ef5c85414235768b19fcc2295504cc98b758075281')
pkgver() {
cd "${pkgname%-git}"
@@ -48,8 +45,6 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
patch -p1 -i "../0001_v8_sandbox_enable.patch"
- patch -p1 -i "../0002_include_cstdint.patch"
- patch -p1 -i "../0003_include_cstdint.patch"
}
build() {