summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Hentschel (hpmachining)2020-02-22 18:36:02 -0500
committerPaul Hentschel (hpmachining)2020-02-22 18:36:02 -0500
commit8adc037c5d3cc437cb90012129d49c033c505005 (patch)
tree53c5f8328377038ad42ac03bff0e8e9580c701b1
parentf405525028044f9f39373c44f9bde8bd55a599c0 (diff)
downloadaur-8adc037c5d3cc437cb90012129d49c033c505005.tar.gz
Added sed to include some needed files.
All files that are needed were not being included in the Install section of the SConstruct scons file.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2704b0784829..d477fb8d0b27 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cbang-git
pkgdesc = A library of cross-platform C++ utilities
- pkgver = 1.3.2.r81.g9db3c75
+ pkgver = 1.3.3.r4.g32940672
pkgrel = 1
url = https://github.com/CauldronDevelopmentLLC/cbang
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 636451899ae9..b3e38cbc02c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: greyltc
pkgname=cbang-git
-pkgver=1.3.2.r81.g9db3c75
+pkgver=1.3.3.r4.g32940672
pkgrel=1
pkgdesc="A library of cross-platform C++ utilities"
arch=('x86_64')
@@ -40,6 +40,7 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
+ sed -i "/files = Glob('src\/cbang\/%s\/\*.h'/a\ files += Glob('include/cbang/%s/*.h' % dir)" SConstruct
sed -i "20i\ conf.CBRequireLib('v8_libplatform')" config/v8/__init__.py
}