summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Hentschel (hpmachining)2023-07-19 11:37:47 -0400
committerPaul Hentschel (hpmachining)2023-07-19 11:37:47 -0400
commitb55a73bcd4a3d5667639583f0ee53d3efba146fa (patch)
tree3ad15ae87133a355950c768fecde002449deb8ce
parentec39b9b7a527970fcf077036a3170c480e496794 (diff)
downloadaur-b55a73bcd4a3d5667639583f0ee53d3efba146fa.tar.gz
Added patch to include <cstdint> in BIP39Words.h
-rw-r--r--.SRCINFO4
-rw-r--r--0003_include_cstdint.patch13
-rw-r--r--PKGBUILD9
3 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ecbc141d322..c64b9e6bf3d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cbang-git
pkgdesc = A library of cross-platform C++ utilities
- pkgver = r1486.83595737
+ pkgver = r1511.ebab9fae
pkgrel = 1
url = https://github.com/CauldronDevelopmentLLC/cbang
arch = x86_64
@@ -23,8 +23,10 @@ pkgbase = cbang-git
source = git+https://github.com/CauldronDevelopmentLLC/cbang.git
source = 0001_v8_sandbox_enable.patch
source = 0002_include_cstdint.patch
+ source = 0003_include_cstdint.patch
sha256sums = SKIP
sha256sums = 75eff0bcd04293990f8dfb0771562356ccac2a7f40a06df0c0ba515fcdf4126a
sha256sums = 0137c007c7596cbd9d9f7194cd6e1aaf11819489c815c57b29b9873523d25cd7
+ sha256sums = 170101a781c105ed83225bfd0387348560d2dd89eede72de45fee60a6ba1a51a
pkgname = cbang-git
diff --git a/0003_include_cstdint.patch b/0003_include_cstdint.patch
new file mode 100644
index 000000000000..3c0a82008291
--- /dev/null
+++ b/0003_include_cstdint.patch
@@ -0,0 +1,13 @@
+diff --git a/src/cbang/util/BIP39Words.h b/src/cbang/util/BIP39Words.h
+index f5afca1c..c4c2afe3 100644
+--- a/src/cbang/util/BIP39Words.h
++++ b/src/cbang/util/BIP39Words.h
+@@ -33,7 +33,7 @@
+ #pragma once
+
+ #include <string>
+-
++#include <cstdint>
+
+ namespace cb {
+ class BIP39Words {
diff --git a/PKGBUILD b/PKGBUILD
index 76181143cd62..83d516c5d8ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: greyltc
pkgname=cbang-git
-pkgver=r1486.83595737
+pkgver=r1511.ebab9fae
pkgrel=1
pkgdesc="A library of cross-platform C++ utilities"
arch=('x86_64')
@@ -33,10 +33,12 @@ conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
source=("git+https://github.com/CauldronDevelopmentLLC/cbang.git"
"0001_v8_sandbox_enable.patch"
- "0002_include_cstdint.patch")
+ "0002_include_cstdint.patch"
+ "0003_include_cstdint.patch")
sha256sums=('SKIP'
'75eff0bcd04293990f8dfb0771562356ccac2a7f40a06df0c0ba515fcdf4126a'
- '0137c007c7596cbd9d9f7194cd6e1aaf11819489c815c57b29b9873523d25cd7')
+ '0137c007c7596cbd9d9f7194cd6e1aaf11819489c815c57b29b9873523d25cd7'
+ '170101a781c105ed83225bfd0387348560d2dd89eede72de45fee60a6ba1a51a')
pkgver() {
cd "${pkgname%-git}"
@@ -47,6 +49,7 @@ prepare() {
cd "${pkgname%-git}"
patch -p1 -i "../0001_v8_sandbox_enable.patch"
patch -p1 -i "../0002_include_cstdint.patch"
+ patch -p1 -i "../0003_include_cstdint.patch"
}
build() {