summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-28 14:42:52 -0600
committerBrian Bidulock2015-06-28 14:42:52 -0600
commit4d905c0236f2c0c7ff9aaa3a377f0a6f5bb14c1a (patch)
treee52f98683d7526b5ec2a447daa379bd2071a32a8
downloadaur-4d905c0236f2c0c7ff9aaa3a377f0a6f5bb14c1a.tar.gz
initial version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51bb15e9056a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cbatticon-gtk2
+ pkgdesc = Lightweight and fast battery icon that sits in your system tray
+ pkgver = 1.4.2
+ pkgrel = 1
+ url = https://github.com/valr/cbatticon
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ depends = libnotify
+ depends = gtk2
+ provides = cbatticon
+ conflicts = cbatticon
+ source = https://github.com/valr/cbatticon/archive/1.4.2.tar.gz
+ sha256sums = 987d979c426c12d7ef6ce7856a7c0d0d0a70720cafcada9ba6a4800d048ef502
+
+pkgname = cbatticon-gtk2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6764af331636
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 123201 2014-11-27 12:40:50Z arodseth $
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Valère Monseur (valr) <valere dot monseur at ymail dot com>
+
+pkgname=cbatticon-gtk2
+_pkgname=cbatticon
+pkgver=1.4.2
+pkgrel=1
+pkgdesc='Lightweight and fast battery icon that sits in your system tray'
+arch=('x86_64' 'i686')
+url='https://github.com/valr/cbatticon'
+license=('GPL2')
+depends=('libnotify' 'gtk2')
+provides=('cbatticon')
+conflicts=('cbatticon')
+source=("https://github.com/valr/$_pkgname/archive/$pkgver.tar.gz")
+sha256sums=('987d979c426c12d7ef6ce7856a7c0d0d0a70720cafcada9ba6a4800d048ef502')
+
+build() {
+ make -C "$_pkgname-$pkgver" WITH_NOTIFY=1 WITH_GTK3=0
+}
+
+package() {
+ make -C "$_pkgname-$pkgver" PREFIX="$pkgdir/usr" install
+}
+
+# vim:set ts=2 sw=2 et: