summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBakasura2019-03-31 23:37:30 -0500
committerBakasura2019-03-31 23:37:30 -0500
commitb840af51db58c1800df9e60d76e692002417f4c6 (patch)
treefab0eca0009a05e6b0f45284a9e21d20f339b10b
downloadaur-b840af51db58c1800df9e60d76e692002417f4c6.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
-rw-r--r--disable-debian.patch32
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6f572b18053
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = cbftp-svn
+ pkgdesc = an advanced multi-purpose FTP/FXP client that focuses on efficient large-scale data spreading, while also supporting most regular FTP/FXP use cases in a modern way. It runs in a terminal and provides a semi-graphical user interface through ncurses.
+ pkgver = r1011
+ pkgrel = 1
+ url = https://cbftp.eu
+ arch = x86_64
+ license = MIT
+ makedepends = subversion
+ makedepends = gcc
+ depends = openssl
+ depends = ncurses
+ provides = cbftp
+ provides = cbftp-svn
+ conflicts = cbftp
+ replaces = cbftp
+ source = svn+https://cbftp.eu/svn/cbftp/
+ source = disable-debian.patch
+ sha256sums = SKIP
+ sha256sums = 50d12919d89186921cfe89d434a96c896ccd05a5eb466716a72e1ff47d5f0b0c
+
+pkgname = cbftp-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b393f9ed22e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Bakasura <bakasura@protonmail.ch>
+
+pkgname=cbftp-svn
+pkgver=r1011
+pkgrel=1
+pkgdesc='an advanced multi-purpose FTP/FXP client that focuses on efficient large-scale data spreading, while also supporting most regular FTP/FXP use cases in a modern way. It runs in a terminal and provides a semi-graphical user interface through ncurses.'
+arch=('x86_64')
+url='https://cbftp.eu'
+depends=('openssl' 'ncurses')
+makedepends=('subversion' 'gcc')
+optdepends=()
+provides=('cbftp' 'cbftp-svn')
+conflicts=('cbftp')
+replaces=('cbftp')
+license=('MIT')
+_srcname=cbftp
+source=("svn+https://cbftp.eu/svn/cbftp/" "disable-debian.patch")
+sha256sums=('SKIP'
+ '50d12919d89186921cfe89d434a96c896ccd05a5eb466716a72e1ff47d5f0b0c')
+
+pkgver() {
+ cd "$_srcname"
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+build() {
+ cd "$_srcname"
+ make
+}
+
+prepare() {
+ cd "$_srcname"
+ patch --forward --strip=1 --input="${srcdir}/disable-debian.patch"
+}
+
+package() {
+ cd "$_srcname"
+ install -D -m775 bin/* -t "${pkgdir}/usr/bin"
+}
diff --git a/disable-debian.patch b/disable-debian.patch
new file mode 100644
index 000000000000..0d9424a49d7a
--- /dev/null
+++ b/disable-debian.patch
@@ -0,0 +1,32 @@
+diff -cr cbftp-r1011.o/Makefile.inc cbftp-r1011/Makefile.inc
+*** cbftp-r1011.o/Makefile.inc 2019-03-17 04:15:01.000000000 -0500
+--- cbftp-r1011/Makefile.inc 2019-03-31 21:46:53.009762000 -0500
+***************
+*** 38,42 ****
+ ifeq ($(UNAME_S),Darwin)
+ LINKFLAGS+=-lncurses
+ else
+! LINKFLAGS+=-lncursesw
+ endif
+--- 38,42 ----
+ ifeq ($(UNAME_S),Darwin)
+ LINKFLAGS+=-lncurses
+ else
+! LINKFLAGS+=-lncurses
+ endif
+diff -cr cbftp-r1011.o/src/ui/ncurseswrap.h cbftp-r1011/src/ui/ncurseswrap.h
+*** cbftp-r1011.o/src/ui/ncurseswrap.h 2019-03-17 04:15:01.000000000 -0500
+--- cbftp-r1011/src/ui/ncurseswrap.h 2019-03-31 22:05:16.467017954 -0500
+***************
+*** 4,8 ****
+ #ifdef __APPLE__
+ #include <ncurses.h>
+ #else
+! #include <ncursesw/curses.h>
+ #endif
+--- 4,8 ----
+ #ifdef __APPLE__
+ #include <ncurses.h>
+ #else
+! #include <ncurses.h>
+ #endif