summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPythonShell2016-12-11 14:53:33 +0000
committerPythonShell2016-12-11 14:53:33 +0000
commit68f759438fc3b82bbb811f38e6320dc5f4ca65a9 (patch)
tree408511ec25c2bec41eabcc086ad0b141b744e0f8
parent2631b807441459cbfa587fe073c2887941f453ad (diff)
downloadaur-68f759438fc3b82bbb811f38e6320dc5f4ca65a9.tar.gz
version 5.6 pkgrel 1
Signed-off-by: PythonShell <pythonshell@yeah.net>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cffca2b4a395..4cbd1a92d71c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cbmc
pkgdesc = Bounded Model Checking for ANSI-C
- pkgver = 5.5
+ pkgver = 5.6
pkgrel = 1
url = http://www.cprover.org/cbmc/
arch = i686
@@ -16,8 +16,8 @@ pkgbase = cbmc
conflicts = cbmc
conflicts = cbmc-git
conflicts = cbmc-bin
- source = https://github.com/diffblue/cbmc/archive/cbmc-5.5.tar.gz
- sha256sums = 748dbdfe37fb91b2755fdeaa61d20aa0b3a18df184d6be6ec283e7f2492537d9
+ source = https://github.com/diffblue/cbmc/archive/cbmc-5.6.tar.gz
+ sha256sums = c6bef63ec42816d0add995ea3b2a5344845cc31f0a6b9e4b8a18df8bb8ad904f
pkgname = cbmc
diff --git a/PKGBUILD b/PKGBUILD
index 6f400d0c53f9..6b9580f18d6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Python Shell <pythonshell@yeah.net>
pkgname=cbmc
-pkgver=5.5
+pkgver=5.6
pkgrel=1
pkgdesc="Bounded Model Checking for ANSI-C"
arch=('i686' 'x86_64')
@@ -11,13 +11,15 @@ depends=('flex' 'bison')
makedepends=('patch' 'make' 'perl-libwww' 'perl-lwp-protocol-https')
provides=('cbmc')
conflicts=('cbmc' 'cbmc-git' 'cbmc-bin')
-source=("https://github.com/diffblue/cbmc/archive/cbmc-5.5.tar.gz")
-sha256sums=('748dbdfe37fb91b2755fdeaa61d20aa0b3a18df184d6be6ec283e7f2492537d9')
+source=("https://github.com/diffblue/cbmc/archive/cbmc-5.6.tar.gz")
+sha256sums=('c6bef63ec42816d0add995ea3b2a5344845cc31f0a6b9e4b8a18df8bb8ad904f')
_pkg_src_root="${pkgname}-${pkgname}-${pkgver}"
build() {
cd "${srcdir}/${_pkg_src_root}/src/"
+ # Makefile typo fix
+ sed -i '/libzip_1.1.2.orig/a\\t\@mv libzip_1.1.2.orig.tar.gz libzip-1.1.2.tar.gz' Makefile
make minisat2-download
make libzip-download zlib-download
make libzip-build