summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPythonShell2015-06-13 11:12:15 +0000
committerPythonShell2015-06-13 11:12:15 +0000
commit6130b90128b310a520a36514913ef62f42721153 (patch)
tree54e32333872539943f537648e5d96d013a818ec0
downloadaur-6130b90128b310a520a36514913ef62f42721153.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e43db783760d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cbmc-bin
+ pkgdesc = Bounded Model Checking for ANSI-C
+ pkgver = 5.1
+ pkgrel = 2
+ url = http://www.cprover.org/cbmc/
+ arch = i686
+ arch = x86_64
+ license = custom
+ provides = cbmc
+ conflicts = cbmc
+ conflicts = cbmc-bin
+ source = http://www.cprover.org/cbmc/download/cbmc-5-1-linux-32.tgz
+ sha256sums = 9b9775340b8136e6d83d5a4a689dc84f5f2d905281eb2f3ad71611d8f42e03f8
+
+pkgname = cbmc-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e10048be631
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Python Shell <pythonshell@yeah.net>
+# Contributor: Johannes Schlatow <johannes.schlatow@googlemail.com>
+
+pkgname=cbmc-bin
+pkgver=5.1
+pkgrel=2
+pkgdesc="Bounded Model Checking for ANSI-C"
+arch=('i686' 'x86_64')
+url="http://www.cprover.org/cbmc/"
+license=('custom')
+provides=('cbmc')
+conflicts=('cbmc' 'cbmc-bin')
+if test "$CARCH" == x86_64; then
+ source=("http://www.cprover.org/cbmc/download/cbmc-5-1-linux-64.tgz")
+ sha256sums=('7662f727f52ba9ad6bc280ea0bd26cfe219bf03e30ffb34d5bc745d6a6a217c8')
+else
+ source=("http://www.cprover.org/cbmc/download/cbmc-5-1-linux-32.tgz")
+ sha256sums=('9b9775340b8136e6d83d5a4a689dc84f5f2d905281eb2f3ad71611d8f42e03f8')
+fi
+
+package() {
+ install -D "${srcdir}/cbmc" "${pkgdir}/usr/bin/cbmc"
+ install -D "${srcdir}/hw-cbmc" "${pkgdir}/usr/bin/hw-cbmc"
+ install -D "${srcdir}/goto-cc" "${pkgdir}/usr/bin/goto-cc"
+ install -D "${srcdir}/goto-instrument" "${pkgdir}/usr/bin/goto-instrument"
+ install -D -m644\
+ "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/cbmc/LICENSE"
+}