summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2017-04-28 10:11:19 -0700
committerMike Swanson2017-04-28 10:11:19 -0700
commit58b18d730914a414846256e42972942258948369 (patch)
tree5f1cc8eb247411098460b1fcf2a3dfae6a558df4
parent699cc649392a7d71605164c068e3745ac503c7f5 (diff)
downloadaur-58b18d730914a414846256e42972942258948369.tar.gz
Install a profile.d file for CC65_HOME
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
-rw-r--r--cc65.sh1
3 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f00901523e7e..bcd12973a958 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Apr 28 17:08:38 UTC 2017
pkgbase = cc65-git
pkgdesc = C compiler for 6502 family microprocessors
- pkgver = 2.13.3.r6521.a85ac88
+ pkgver = 2.13.3.r7139.18b0aaf9f
pkgrel = 1
url = https://cc65.github.io/cc65/
arch = i686
arch = x86_64
license = BSD
+ makedepends = git
makedepends = linuxdoc-tools
provides = cc65
conflicts = cc65
source = git+https://github.com/cc65/cc65
- sha256sums = SKIP
+ source = cc65.sh
+ sha512sums = SKIP
+ sha512sums = eb45cf08a0fdc85ce34535447add9bcf4139e5515af229f16608b94f2a1cb8ab3cba4d79652212244f0657902c0a3768352f9a2bde7891f6e462a1e01d9dee6b
pkgname = cc65-git
diff --git a/PKGBUILD b/PKGBUILD
index 0b42e79e9fbe..c665acb659e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
pkgname=cc65-git
-pkgver=2.13.3.r6521.a85ac88
+pkgver=2.13.3.r7139.18b0aaf9f
pkgrel=1
pkgdesc='C compiler for 6502 family microprocessors'
arch=('i686' 'x86_64')
-makedepends=('linuxdoc-tools')
+makedepends=('git' 'linuxdoc-tools')
conflicts=('cc65')
provides=('cc65')
license=('BSD')
url='https://cc65.github.io/cc65/'
-source=(git+https://github.com/cc65/cc65)
-sha256sums=('SKIP')
+source=(git+https://github.com/cc65/cc65 cc65.sh)
+sha512sums=('SKIP'
+ 'eb45cf08a0fdc85ce34535447add9bcf4139e5515af229f16608b94f2a1cb8ab3cba4d79652212244f0657902c0a3768352f9a2bde7891f6e462a1e01d9dee6b')
pkgver() {
cd "$srcdir/${pkgname/-git//}"
- # Not tags (yet) in the Git repo. Start off with the version of last release.
+ # No tags (yet) in the Git repo. Start off with the version of last release.
printf "2.13.3.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
@@ -29,5 +30,6 @@ package() {
cd "$srcdir/${pkgname/-git//}"
make DESTDIR="$pkgdir" prefix=/usr install
+ install -Dm644 ../cc65.sh "$pkgdir/etc/profile.d/cc65.sh"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/license"
}
diff --git a/cc65.sh b/cc65.sh
new file mode 100644
index 000000000000..19cad9116581
--- /dev/null
+++ b/cc65.sh
@@ -0,0 +1 @@
+export CC65_HOME=/usr/share/cc65