summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Hochmann2020-03-08 01:27:18 +0100
committerPhilipp Hochmann2020-03-08 01:27:18 +0100
commit0a43276b0d18fbf6ac1365688cf1ecb52f84e9f0 (patch)
tree7095e8f5183c7dc6518903921bf77e735095ae27
downloadaur-0a43276b0d18fbf6ac1365688cf1ecb52f84e9f0.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD61
-rw-r--r--ccalc-1.5.0.tar.gzbin0 -> 34611 bytes
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..985f49765c76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ccalc
+ pkgdesc = Scientific calculator in which you can define new functions and constants
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://github.com/PhilippHochmann/Calculator
+ arch = x86_64
+ license = GPL3
+ depends = readline
+ source = ccalc-1.5.0.tar.gz
+ md5sums = ca56a7612da5fa50ff5b69e0569a4b78
+
+pkgname = ccalc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cdafa298fd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Philipp Hochmann <phil.hochmann[ät]gmail[dot]com>
+pkgname=ccalc
+pkgver=1.5.0
+pkgrel=1
+epoch=
+pkgdesc="Scientific calculator in which you can define new functions and constants"
+arch=('x86_64')
+url="https://github.com/PhilippHochmann/Calculator"
+license=('GPL3')
+groups=()
+depends=('readline')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver.tar.gz")
+noextract=()
+md5sums=('ca56a7612da5fa50ff5b69e0569a4b78')
+validpgpkeys=()
+
+prepare() {
+ echo "Nothing to prepare"
+}
+
+build() {
+ # - - - - - - - Build configuration - - - - - - -
+ use_readline=true
+ # - - - - - - - - - - - - - - - - - - - - - - - -
+
+ LFLAGS="-lm"
+ DEFINES=""
+ CFLAGS="-std=c99 -Wall -Wextra -Werror -pedantic"
+ FILES="*/*.c *.c"
+ BIN="ccalc"
+
+ if [ "$use_readline" = true ]; then
+ LFLAGS="$LFLAGS -lreadline"
+ DEFINES="$DEFINES -DUSE_READLINE"
+ fi
+
+ cd "$pkgname-$pkgver"
+ gcc $DEFINES -O3 $CFLAGS $FILES -o $BIN $LFLAGS
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ if test ! -f ccalc; then
+ echo "Compilation error"
+ fi
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin/
+ mv "$pkgname-$pkgver"/ccalc $pkgdir/usr/bin
+}
diff --git a/ccalc-1.5.0.tar.gz b/ccalc-1.5.0.tar.gz
new file mode 100644
index 000000000000..2ec9c3f9aa70
--- /dev/null
+++ b/ccalc-1.5.0.tar.gz
Binary files differ