summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpushsla2018-11-16 19:32:59 +0300
committerpushsla2018-11-16 19:32:59 +0300
commit91827c29ed68f913bc8e84f6fcde199668896564 (patch)
treee02050b637f10d384da38469a9cc735878eb2821
downloadaur-91827c29ed68f913bc8e84f6fcde199668896564.tar.gz
v1.0 basic functionality
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..53ed376b06a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ccd-python-git
+ pkgdesc = Cute ChDir written on Python that finds directories
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/pushsla/CuteCD
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = python>=3.6.0
+ source = https://github.com/pushsla/CuteCD
+ md5sums = 9ece0f2a171e08f370b9461e225cab4d
+
+pkgname = ccd-python-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df4f3ea1cd85
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: push2001sla@gmail.com
+pkgname=ccd-python-git
+pkgver=1.0
+pkgrel=1
+epoch=
+pkgdesc="Cute ChDir written on Python that finds directories"
+arch=('any')
+url="https://github.com/pushsla/CuteCD"
+license=('unknown')
+groups=()
+depends=('python>=3.6.0')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/pushsla/CuteCD")
+noextract=()
+md5sums=('9ece0f2a171e08f370b9461e225cab4d')
+validpgpkeys=()
+prepare() {
+ rm -rf "$pkgname-$pkgver"
+ git clone "$source" "$pkgname-$pkgver"
+}
+package() {
+ cd "$pkgname-$pkgver"
+ mkdir -p "$pkgdir/usr/bin/"
+ cp ccd-src.py "$pkgdir/usr/bin/ccd"
+}