summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMr.Smith19742023-08-11 07:53:39 +0300
committerMr.Smith19742023-08-11 07:53:39 +0300
commitdc5c92d3262ba2cda3548058abe4c39605276cfc (patch)
treea0e51d4cd2d76db0df635dc0bfe01022cc8c4948
parentad4b8524f9840a7981d27cd4bb1d69a95a94d152 (diff)
downloadaur-dc5c92d3262ba2cda3548058abe4c39605276cfc.tar.gz
Updated build
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 806db92042f7..b4e2c18804c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = ccdciel
pkgdesc = A CCD capture software intended for the amateur astronomer.
- pkgver = 0.9.82
+ pkgver = 0.9.84
pkgrel = 1
url = https://www.ap-i.net/ccdciel
arch = x86_64
license = GPL
depends = libpasastro
- source = https://sourceforge.net/projects/ccdciel/files/ccdciel_0.9.82/ccdciel-0.9.82-2979-linux_x86_64.tar.xz
- md5sums = 7280c8d219ee6fdd88580ef432c19344
+ depends = gtk2
+ optdepends = libraw: to open DSLR raw files
+ conflicts = ccdciel-git
+ source = https://sourceforge.net/projects/ccdciel/files/ccdciel_0.9.84/ccdciel-0.9.84-3102-linux_x86_64.tar.xz
+ sha256sums = 8dddd0c16c9d6c1f3026fac78e1cb610d74b8d8e2adb636c426fa72e0f8af324
pkgname = ccdciel
diff --git a/PKGBUILD b/PKGBUILD
index 79057590cd8d..117744b51457 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
# Maintainer: rapiertg <rapiertg@gmail.com>
pkgname=ccdciel
-pkgver=0.9.82
+pkgver=0.9.84
pkgrel=1
+_pkgcom=3102
pkgdesc="A CCD capture software intended for the amateur astronomer."
arch=('x86_64')
url="https://www.ap-i.net/ccdciel"
license=('GPL')
-depends=('libpasastro')
-md5sums=("7280c8d219ee6fdd88580ef432c19344")
-source=("https://sourceforge.net/projects/ccdciel/files/ccdciel_"$pkgver"/ccdciel-"$pkgver"-2979-linux_"${arch}".tar.xz")
+depends=('libpasastro' 'gtk2')
+optdepends=('libraw: to open DSLR raw files')
+conflicts=('ccdciel-git')
+sha256sums=('8dddd0c16c9d6c1f3026fac78e1cb610d74b8d8e2adb636c426fa72e0f8af324')
+source=("https://sourceforge.net/projects/ccdciel/files/ccdciel_"$pkgver"/ccdciel-"$pkgver"-${_pkgcom}-linux_"${arch}".tar.xz")
package() {
mkdir "${pkgdir}"/usr/
- tar -xf "${srcdir}"/ccdciel-"$pkgver"-2979-linux_"${arch}".tar.xz --strip 1 -C "${pkgdir}/usr/"
+ tar -xf "${srcdir}"/ccdciel-"$pkgver"-${_pkgcom}-linux_"${arch}".tar.xz --strip 1 -C "${pkgdir}/usr/"
chown -R root:root "${pkgdir}/usr/"
}