summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-06-12 21:59:02 +0200
committeroli2015-06-12 21:59:02 +0200
commit78f071891a3a019b7cef49ec1518308cebe4c94f (patch)
tree45b5ccf8e37d8b925b247992a6b35a841ff24fb7
downloadaur-78f071891a3a019b7cef49ec1518308cebe4c94f.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rwxr-xr-xPKGBUILD33
-rwxr-xr-xccfeinstall.conf7
-rw-r--r--install.patch43
4 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e78e4fe0e8bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ccfe
+ pkgdesc = Is a tool to quickly supply an interactive screen-oriented interface to command line scripts and commands.
+ pkgver = 1.56
+ pkgrel = 3
+ url = http://ccfe.altervista.org
+ arch = any
+ license = GPL2
+ depends = perl-curses-panels-menus-forms
+ source = ccfe.tar.gz::http://ccfe.altervista.org/dnload/dnload.php?fname=ccfe-1.56.tar.gz
+ source = ccfeinstall.conf
+ source = install.patch
+ md5sums = ca5d43c0850235c213a083508edb77b3
+ md5sums = 9f78a2fa9c90676d60fa9cae28393733
+ md5sums = 4ce34496f93ce68a7f0bde297d18acfd
+
+pkgname = ccfe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..7f564633c6b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Otto Sabart <seberm[at]gmail[dot]com>
+# Maintainer: Jose Riha <jose 1711 gmail com>
+
+pkgname=ccfe
+pkgver=1.56
+pkgrel=3
+pkgdesc="Is a tool to quickly supply an interactive screen-oriented interface to command line scripts and commands."
+url="http://ccfe.altervista.org"
+arch=('any')
+license=('GPL2')
+depends=('perl-curses-panels-menus-forms')
+source=("${pkgname}.tar.gz::http://ccfe.altervista.org/dnload/dnload.php?fname=${pkgname}-${pkgver}.tar.gz" 'ccfeinstall.conf' 'install.patch')
+
+md5sums=('ca5d43c0850235c213a083508edb77b3'
+ '9f78a2fa9c90676d60fa9cae28393733'
+ '4ce34496f93ce68a7f0bde297d18acfd')
+
+build() {
+ true
+}
+
+package() {
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p0 < $srcdir/install.patch install.sh
+ ./install.sh -b -p "${pkgdir}/usr" \
+ -c "${pkgdir}/etc/${pkgname}" \
+ -o "${pkgdir}/var/log/${pkgname}" \
+ -d "${pkgdir}/usr/share/doc" \
+ -a "${pkgdir}/usr/share/man" \
+ -m "${pkgdir}/usr/share/${pkgname}/msg"
+ install -D -m644 "${srcdir}/ccfeinstall.conf" "${pkgdir}/etc/${pkgname}/ccfeinstall.conf"
+}
diff --git a/ccfeinstall.conf b/ccfeinstall.conf
new file mode 100755
index 000000000000..fccf1762ab97
--- /dev/null
+++ b/ccfeinstall.conf
@@ -0,0 +1,7 @@
+ETCDIR="/etc/ccfe"
+BINDIR="/usr/bin"
+LIBDIR="/usr/lib"
+LOGDIR="/var/log/ccfe"
+MSGDIR="/usr/share/ccfe/msg"
+MANDIR="/usr/share/man"
+DOCDIR="/usr/share/doc"
diff --git a/install.patch b/install.patch
new file mode 100644
index 000000000000..1cf7acdf84cb
--- /dev/null
+++ b/install.patch
@@ -0,0 +1,43 @@
+79,80c79,80
+< - directory ${LIBDIR}/ccfe/ccfe.menu (the previous test menu)
+< - file ${LIBDIR}/ccfe/it_works.txt (this file)
+---
+> - directory /usr/lib/ccfe/ccfe.menu (the previous test menu)
+> - file /usr/lib/ccfe/it_works.txt (this file)
+121a122,128
+> exp_etcdir="\/etc\/ccfe"
+> exp_bindir="\/usr\/bin"
+> exp_libdir="\/usr\/lib"
+> exp_logdir="\/var\/log\/ccfe"
+> exp_msgdir="\/usr\/share\/ccfe\/msg"
+> exp_docdir="\/usr\/share\/doc"
+>
+158,167c165,174
+< cat <<EOT > "$ETCDIR/$SAVED_INFO"
+< # Installed on $(date)
+< ETCDIR="$ETCDIR"
+< BINDIR="$BINDIR"
+< LIBDIR="$LIBDIR"
+< LOGDIR="$LOGDIR"
+< MSGDIR="$MSGDIR"
+< MANDIR="$MANDIR"
+< DOCDIR="$DOCDIR"
+< EOT
+---
+> #cat <<EOT > "$ETCDIR/$SAVED_INFO"
+> ## Installed on $(date)
+> #ETCDIR="$ETCDIR"
+> #BINDIR="$BINDIR"
+> #LIBDIR="$LIBDIR"
+> #LOGDIR="$LOGDIR"
+> #MSGDIR="$MSGDIR"
+> #MANDIR="$MANDIR"
+> #DOCDIR="$DOCDIR"
+> #EOT
+316,321d322
+< exp_etcdir=$(echo $ETCDIR | sed -e 's/\//\\\//g')
+< exp_bindir=$(echo $BINDIR | sed -e 's/\//\\\//g')
+< exp_libdir=$(echo $LIBDIR | sed -e 's/\//\\\//g')
+< exp_logdir=$(echo $LOGDIR | sed -e 's/\//\\\//g')
+< exp_msgdir=$(echo $MSGDIR | sed -e 's/\//\\\//g')
+< exp_docdir=$(echo $DOCDIR | sed -e 's/\//\\\//g')