summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-28 10:51:11 +0100
committerAlexander F. Rødseth2019-03-28 10:51:11 +0100
commit1d1988a55eb3e0c4a7cb68ac5e4b11bcab9aa516 (patch)
tree60dc88c92ac35aed7e21ffcd27bf4b56ab8a7be9
downloadaur-1d1988a55eb3e0c4a7cb68ac5e4b11bcab9aa516.tar.gz
Move ccgo to AUR
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b01b618da3f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu Mar 28 09:51:01 UTC 2019
+pkgbase = ccgo
+ pkgdesc = Play the game of Go with gnugo or against other players on IGS
+ pkgver = 0.3.6.5
+ pkgrel = 5
+ url = https://ccdw.org/~cjj/prog/ccgo/
+ arch = x86_64
+ license = GPL
+ depends = gtkmm
+ depends = gconfmm
+ source = https://ccdw.org/~cjj/prog/ccgo/src/ccgo-0.3.6.5.tar.gz
+ sha256sums = d12be7fb9170d650ae78197983fac05af21ddbf47f7b1a2a14de9aa832ed602c
+
+pkgname = ccgo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b99174284a3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: Guillem Rieu <guillemr@gmx.net>
+
+pkgname=ccgo
+pkgver=0.3.6.5
+pkgrel=5
+pkgdesc='Play the game of Go with gnugo or against other players on IGS'
+arch=(x86_64)
+url='https://ccdw.org/~cjj/prog/ccgo/'
+license=(GPL)
+depends=(gtkmm gconfmm)
+source=("https://ccdw.org/~cjj/prog/$pkgname/src/$pkgname-$pkgver.tar.gz")
+sha256sums=('d12be7fb9170d650ae78197983fac05af21ddbf47f7b1a2a14de9aa832ed602c')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ find -name '*.hh' -type f -exec sed -i '/sigc++\/object.h/d' {} +
+ find -name '*.cc' -type f -exec sed -i 's/(bind(/(sigc::bind(/' {} +
+}
+
+build() {
+ cd $pkgname-$pkgver
+
+ ./configure --prefix=/usr
+ CXXFLAGS="$CXXFLAGS -std=c++11 -fpermissive" make
+}
+
+package() {
+ DESTDIR="$pkgdir" make -C $pkgname-$pkgver install
+}
+
+# getver: ccdw.org/~cjj/prog/ccgo/ChangeLog
+# vim: ts=2 sw=2 et: