summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeyslan G. Bem2017-02-10 20:30:17 -0300
committerGeyslan G. Bem2017-02-10 20:30:17 -0300
commitafec039d2bb2c0a0a7e389b4b933c59e47672d03 (patch)
tree9b7fefd39a35b17954d4751e074839f05f3711c7
downloadaur-afec039d2bb2c0a0a7e389b4b933c59e47672d03.tar.gz
initial
Signed-off-by: Geyslan G. Bem <geyslan@gmail.com>
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
-rw-r--r--ccid-morpho.install15
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12cd5396739a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ccid-morpho
+ pkgdesc = A USB Chip/Smart Card Interface Device driver (SAFRAN MORPHO YpsID Token)
+ pkgver = 1.4.3_1morpho
+ pkgrel = 1
+ url = https://github.com/geyslan/morpho
+ install = ccid-morpho.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ license = GPL
+ depends = pcsclite
+ depends = libusb
+ optdepends = pcsc-tools
+ provides = ccid=1.4.3_1morpho
+ conflicts = ccid
+ source_i686 = https://github.com/geyslan/morpho/raw/master/libccid_1.4.3-1morpho_i386.deb
+ md5sums_i686 = 429f3f59c3781a62259b7fe701983515
+ source_x86_64 = https://github.com/geyslan/morpho/raw/master/libccid_1.4.3-1morpho_amd64.deb
+ md5sums_x86_64 = 20fb32fb2a418f1508b5a482b6c1b21b
+
+pkgname = ccid-morpho
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50f82f7a4d52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Geyslan G. Bem <geyslan@gmail.com>
+
+pkgname=ccid-morpho
+pkgver=1.4.3_1morpho
+_pkgver=${pkgver//_/-}
+pkgrel=1
+pkgdesc="A USB Chip/Smart Card Interface Device driver (SAFRAN MORPHO YpsID Token)"
+arch=('i686' 'x86_64')
+url="https://github.com/geyslan/morpho"
+license=('LGPL' 'GPL')
+depends=('pcsclite' 'libusb')
+optdepends=('pcsc-tools')
+provides=("ccid=${pkgver}")
+conflicts=('ccid')
+install="$pkgname.install"
+source_x86_64=("https://github.com/geyslan/morpho/raw/master/libccid_${_pkgver}_amd64.deb")
+source_i686=("https://github.com/geyslan/morpho/raw/master/libccid_${_pkgver}_i386.deb")
+md5sums_i686=('429f3f59c3781a62259b7fe701983515')
+md5sums_x86_64=('20fb32fb2a418f1508b5a482b6c1b21b')
+
+prepare() {
+ tar zxf data.tar.gz
+}
+
+package() {
+ cp -R usr "$pkgdir"
+
+ # fix doc tree to standard
+ # https://wiki.archlinux.org/index.php/Arch_packaging_standards#Directories
+ mv "$pkgdir"/usr/share/doc/{libccid,$pkgname}
+
+ # move the configuration file to /etc and create a symbolic link
+ mkdir -p "$pkgdir/etc"
+ mv "$pkgdir/usr/lib/pcsc/drivers/ifd-ypsid.bundle/Contents/Info.plist" "$pkgdir/etc/libccid_Info.plist"
+ ln -s /etc/libccid_Info.plist "$pkgdir/usr/lib/pcsc/drivers/ifd-ypsid.bundle/Contents/Info.plist"
+}
+
diff --git a/ccid-morpho.install b/ccid-morpho.install
new file mode 100644
index 000000000000..768c63f78630
--- /dev/null
+++ b/ccid-morpho.install
@@ -0,0 +1,15 @@
+## arg 1: the new package version
+post_install() {
+ echo "--"
+ echo " You may have to enable and start pcscd (pcsclite) service, e.g."
+ echo " $ systemctl enable pcscd"
+ echo " $ systemctl start pcscd"
+ echo "--"
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ post_install
+}
+