summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-11-17 23:18:39 +0100
committerhaawda2017-11-17 23:18:39 +0100
commit6e643db9efa3324694506923165ffa2c3ce2adb7 (patch)
tree8441b4be993e8b7726e6d36db7b14a0b8d11b6dd
parent4d985e588a7e0c70698dc6f0002417a2633bc67b (diff)
downloadaur-6e643db9efa3324694506923165ffa2c3ce2adb7.tar.gz
fetch binaries, so it works
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30f21e779686..994f3d1b21c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
# Generated by mksrcinfo v8
-# Tue Nov 14 19:30:22 UTC 2017
+# Fri Nov 17 22:17:46 UTC 2017
pkgbase = ccl-git
pkgdesc = The Clozure Common Lisp implementation
pkgver = 4730.030b03e3
- pkgrel = 1
+ pkgrel = 2
url = http://ccl.clozure.com/
arch = i686
arch = x86_64
license = APACHE
- makedepends = svn
- makedepends = gcc6
+ makedepends = git
depends = bash
optdepends = java-environment: for using emaple file jfli.jar
provides = common-lisp
@@ -18,7 +17,9 @@ pkgbase = ccl-git
conflicts = ccl-bin
conflicts = ccl
source = git+https://github.com/Clozure/ccl.git
+ source = http://svn.clozure.com/publicsvn/openmcl/trunk/source/scripts/get-binaries
sha1sums = SKIP
+ sha1sums = 3160281c3c8ed63b0019fa00139026d9fdb3259e
pkgname = ccl-git
diff --git a/PKGBUILD b/PKGBUILD
index 7102bb8e7423..7609f2ef6435 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,21 @@
pkgname=ccl-git
pkgver=4730.030b03e3
-pkgrel=1
+pkgrel=2
pkgdesc="The Clozure Common Lisp implementation"
url="http://ccl.clozure.com/"
license=('APACHE')
arch=('i686' 'x86_64')
depends=('bash')
optdepends=('java-environment: for using emaple file jfli.jar')
-makedepends=('svn' 'gcc6')
+makedepends=('git')
provides=('common-lisp' 'cl-asdf' 'ccl')
conflicts=('ccl-bin' 'ccl')
-source=("git+https://github.com/Clozure/ccl.git")
-sha1sums=('SKIP')
-
-_arch=''
[ "${CARCH}" = 'x86_64' ] && _arch=64
[ "${CARCH}" = 'i686' ] && _arch=32
+source=("git+https://github.com/Clozure/ccl.git" http://svn.clozure.com/publicsvn/openmcl/trunk/source/scripts/get-binaries)
+sha1sums=('SKIP'
+ '3160281c3c8ed63b0019fa00139026d9fdb3259e')
pkgver() {
cd ccl
@@ -26,9 +25,13 @@ pkgver() {
}
build() {
- cd ccl/lisp-kernel/linuxx86$_arch
+ cd ccl
+ chmod 700 ../get-binaries
+ ../get-binaries linuxx86
+ cd lisp-kernel/linuxx8664
make
-# echo '(ccl:rebuild-ccl :full t)' | ./lx86cl$_arch -n -Q -b
+ cd ../..
+ echo "(ccl:rebuild-ccl :full t)" | ./lx86cl$_arch --no-init --quiet --batch
}
package() {
@@ -37,8 +40,7 @@ package() {
# install data
install -d "$pkgdir/usr/lib/$pkgname"
cp -a {compiler,level-*,lib*,lisp-kernel,objc-bridge,tools,xdump,lx86cl$_arch*} \
- "$pkgdir/usr/lib/$pkgname"
-
+ "$pkgdir"/usr/lib/$pkgname
# install examples
install -d "$pkgdir/usr/share/$pkgname"
cp -a examples "$pkgdir/usr/share/$pkgname"