summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShengyu Zhang2019-04-12 14:40:54 +0800
committerShengyu Zhang2019-04-12 14:40:54 +0800
commit40cb1251f99a282ae6b4b3167e1c4e0f82cbaf1c (patch)
treee35de2166cd8604702d09d91ebbe453ea8c41d2c
parentc5a13aa72d38c60a41b63a68404116705422b4a5 (diff)
downloadaur-40cb1251f99a282ae6b4b3167e1c4e0f82cbaf1c.tar.gz
Make sure ccls build with clang
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8391aa41b81e..8898ea5ef92d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ccls-git
_pkgname=ccls
pkgver=20190310
-pkgrel=1
+pkgrel=2
pkgdesc='C/C++ language server supporting cross references, hierarchies, completion and semantic highlighting'
arch=('x86_64')
url='https://github.com/MaskRay/ccls'
@@ -24,7 +24,7 @@ prepare() {
build() {
cd $_pkgname
- cmake -H. -Bbuild -DCMAKE_INSTALL_PREFIX=/usr
+ cmake -H. -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_CXX_COMPILER=clang++
cmake --build build
}