summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFangrui Song2019-03-09 01:36:04 -0800
committerFangrui Song2019-03-09 01:36:04 -0800
commit244c3ca71608e72a79a7dbce623ef77c6d385836 (patch)
treed79e5e24d9d9054da69c7dd3438fc3ff8c23c906
parentda515e6fd754a3d6c229eb1cc82076b3b1cb31ec (diff)
downloadaur-244c3ca71608e72a79a7dbce623ef77c6d385836.tar.gz
Change version format; use community/rapidjson
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3463e57901e3..45b5e28d1496 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ccls-git
pkgdesc = C/C++ language server supporting cross references, hierarchies, completion and semantic highlighting
- pkgver = 1825.e4927d2e
+ pkgver = 20190309
pkgrel = 1
url = https://github.com/MaskRay/ccls
arch = x86_64
@@ -10,6 +10,7 @@ pkgbase = ccls-git
makedepends = llvm
depends = clang
depends = llvm-libs
+ depends = rapidjson
source = git+https://github.com/MaskRay/ccls.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2b02b546cd07..71d00a935591 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,24 @@
pkgname=ccls-git
_pkgname=ccls
-pkgver=1825.e4927d2e
+pkgver=20190309
pkgrel=1
pkgdesc='C/C++ language server supporting cross references, hierarchies, completion and semantic highlighting'
arch=('x86_64')
url='https://github.com/MaskRay/ccls'
license=('Apache')
-depends=('clang' 'llvm-libs')
+depends=('clang' 'llvm-libs' 'rapidjson')
makedepends=("cmake" "git" "llvm")
source=('git+https://github.com/MaskRay/ccls.git')
md5sums=('SKIP')
pkgver() {
cd $_pkgname
- printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ TZ=UTC date -d @$(git log -1 --format=%ct) +%Y%m%d
}
prepare() {
cd $_pkgname
- git submodule update --init
}
build() {