summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFangrui Song2019-03-09 23:02:20 -0800
committerFangrui Song2019-03-09 23:02:29 -0800
commitc5a13aa72d38c60a41b63a68404116705422b4a5 (patch)
tree9f94f11a8b5a5b66552d412f1975f738460a93b6
parent244c3ca71608e72a79a7dbce623ef77c6d385836 (diff)
downloadaur-c5a13aa72d38c60a41b63a68404116705422b4a5.tar.gz
Delete LLVM_ENABLE_RTTI and USE_SHARED_LLVM; they are unnecessary since https://github.com/MaskRay/ccls/pull/313
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45b5e28d1496..5ff1358afbe4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ccls-git
pkgdesc = C/C++ language server supporting cross references, hierarchies, completion and semantic highlighting
- pkgver = 20190309
+ pkgver = 20190310
pkgrel = 1
url = https://github.com/MaskRay/ccls
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 71d00a935591..8391aa41b81e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ccls-git
_pkgname=ccls
-pkgver=20190309
+pkgver=20190310
pkgrel=1
pkgdesc='C/C++ language server supporting cross references, hierarchies, completion and semantic highlighting'
arch=('x86_64')
@@ -24,7 +24,7 @@ prepare() {
build() {
cd $_pkgname
- cmake -H. -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DUSE_SHARED_LLVM=on -DLLVM_ENABLE_RTTI=on
+ cmake -H. -Bbuild -DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
}