summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFangrui Song2018-04-08 16:32:00 +0000
committerFangrui Song2018-04-08 16:32:00 +0000
commitd72e3635cd77fb50c55d1f2467f3210512460f9a (patch)
treecf5f036ba87bbdf1e309be9b291b6763c7f4d13f
downloadaur-d72e3635cd77fb50c55d1f2467f3210512460f9a.tar.gz
Initial
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e0aff3965c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ccls-git
+ pkgdesc = C/C++ language server supporting cross references, hierarchies, completion and semantic highlighting
+ pkgver = 1604.d999342
+ pkgrel = 1
+ url = https://github.com/MaskRay/ccls
+ arch = any
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ makedepends = llvm
+ depends = clang
+ source = git+https://github.com/MaskRay/ccls.git
+ md5sums = SKIP
+
+pkgname = ccls-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b909d31ff478
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Fangrui Song <i at maskray.me>
+
+pkgname=ccls-git
+_pkgname=ccls
+pkgver=1604.d999342
+pkgrel=1
+pkgdesc='C/C++ language server supporting cross references, hierarchies, completion and semantic highlighting'
+arch=('any')
+url='https://github.com/MaskRay/ccls'
+license=('MIT')
+depends=('clang')
+makedepends=("cmake" "git" "llvm")
+source=('git+https://github.com/MaskRay/ccls.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $_pkgname
+ git submodule update --init
+ install -d build
+}
+
+build() {
+ cd $_pkgname/build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DSYSTEM_LIBCLANG=On
+ cmake --build .
+}
+
+package() {
+ cd $_pkgname/build
+ make DESTDIR="$pkgdir" install
+}