summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHo Tuan Kiet2018-02-13 23:04:36 +0700
committerHo Tuan Kiet2018-02-13 23:04:36 +0700
commit2c873eaf94398dfcdd55f49d1317e3efc42efaa3 (patch)
tree94af89eeb368502de656b5537ff72474527dbf79
downloadaur-ccminer-allium-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d799740ef78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ccminer-allium-git
+ pkgdesc = Cryptocurrency miner for nVidia GPUs using CUDA (with support for Allium algorithm used by Garlicoin).
+ pkgver = r925.81931e3
+ pkgrel = 1
+ url = http://ccminer.org/
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cuda
+ makedepends = nvidia-utils
+ depends = cuda
+ depends = curl
+ depends = jansson
+ depends = nvidia-utils
+ provides = ccminer
+ conflicts = ccminer
+ options = !emptydirs
+ source = git+https://github.com/lenis0012/ccminer/
+ sha256sums = SKIP
+
+pkgname = ccminer-allium-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bbe3a8e018b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Ho Tuan Kiet <tuankiet65@gmail.com>
+# Maintainer: Omar Pakker <archlinux@opakker.nl>
+
+_pkgname='ccminer'
+pkgname="${_pkgname}-allium-git"
+pkgver=r925.81931e3
+pkgrel=1
+pkgdesc="Cryptocurrency miner for nVidia GPUs using CUDA (with support for Allium algorithm used by Garlicoin)."
+arch=('x86_64')
+url="http://ccminer.org/"
+license=('GPL3')
+depends=('cuda' 'curl' 'jansson' 'nvidia-utils')
+makedepends=('git' 'cuda' 'nvidia-utils')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+options=('!emptydirs')
+source=("git+https://github.com/lenis0012/ccminer/")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "ccminer"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "ccminer"
+
+ ./autogen.sh
+ ./configure CUDA_CFLAGS='--shared --compiler-options "-fPIC"' \
+ --prefix=/usr --sysconfdir=/etc --libdir=/usr/lib --with-cuda=/opt/cuda
+
+ make
+}
+
+package() {
+ cd "ccminer"
+ make DESTDIR="${pkgdir}" install
+}