summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2017-01-07 15:58:15 +0100
committereolianoe2017-01-07 15:58:15 +0100
commit7c3696f89d8834ca9cbd83c30ea87417f43a9701 (patch)
treedde8e030b76430f22d836e7904f27d42ea3f6166
downloadaur-7c3696f89d8834ca9cbd83c30ea87417f43a9701.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD36
-rw-r--r--libccnet.pc.patch8
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ca5f3f96ef2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Sat Jan 7 14:54:34 UTC 2017
+pkgbase = ccnet-server
+ pkgdesc = A framework for writing networked applications in C.
+ pkgver = 6.0.7
+ pkgrel = 1
+ url = https://github.com/haiwen/ccnet-server
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = armv6h
+ license = GPL2
+ makedepends = vala
+ makedepends = libmariadbclient
+ depends = libevent
+ depends = libzdb
+ depends = libsearpc
+ depends = libldap
+ depends = python2
+ options = !makeflags
+ source = ccnet-server-v6.0.7-server.tar.gz::https://github.com/haiwen/ccnet-server/archive/v6.0.7-server.tar.gz
+ source = libccnet.pc.patch
+ sha256sums = 8e8fc38f8f8b3fc7aac7133c835b80df11fb219cf9b60b830cef9025a5daad64
+ sha256sums = 66c3b02c3981db6a80819e0ae103bedadf8dfdf81405a7f75a9cba714acf973f
+
+pkgname = ccnet-server
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7b4db42c16c2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.gz
+*.xz
+*.zip
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..684b4c04d5dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: eolianoe <eolianoe [at] gmail [DoT] com>
+# Contributor: Aaron Lindsay <aaron@aclindsay.com>
+# Contributor: Edvinas Valatka <edacval@gmail.com>
+# Contributor: Adrian Hühn <adrian.huehn@web.de>
+
+pkgname=ccnet-server
+pkgver=6.0.7
+pkgrel=1
+pkgdesc="A framework for writing networked applications in C."
+arch=('i686' 'x86_64' 'armv7h' 'armv6h')
+url="https://github.com/haiwen/${pkgname}"
+license=('GPL2')
+depends=('libevent' 'libzdb' 'libsearpc' 'libldap' 'python2')
+makedepends=('vala' 'libmariadbclient')
+options=('!makeflags')
+source=("${pkgname}-v${pkgver}-server.tar.gz::${url}/archive/v${pkgver}-server.tar.gz"
+ "libccnet.pc.patch")
+sha256sums=('8e8fc38f8f8b3fc7aac7133c835b80df11fb219cf9b60b830cef9025a5daad64'
+ '66c3b02c3981db6a80819e0ae103bedadf8dfdf81405a7f75a9cba714acf973f')
+
+prepare () {
+ cd "${srcdir}/${pkgname}-${pkgver}-server"
+ patch -p1 -i "${srcdir}"/libccnet.pc.patch
+}
+
+build () {
+ cd "${srcdir}/${pkgname}-${pkgver}-server"
+ ./autogen.sh
+ ./configure --enable-ldap --enable-python --enable-console --prefix=/usr PYTHON=/usr/bin/python2
+ make
+}
+
+package () {
+ cd "${srcdir}/${pkgname}-${pkgver}-server"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/libccnet.pc.patch b/libccnet.pc.patch
new file mode 100644
index 000000000000..dcc95e4be272
--- /dev/null
+++ b/libccnet.pc.patch
@@ -0,0 +1,8 @@
+--- a/libccnet.pc.in 2013-01-10 01:35:24.000000000 -0500
++++ b/libccnet.pc.in 2013-01-19 11:31:50.479301798 -0500
+@@ -1,4 +1,4 @@
+-prefix=(DESTDIR)@prefix@
++prefix=@prefix@
+ exec_prefix=@exec_prefix@
+ libdir=@libdir@
+ includedir=@includedir@