summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Redaelli2015-08-18 20:03:05 +0200
committerTimothy Redaelli2015-08-18 20:03:09 +0200
commit18e5e3314d2406e33aed5bbbffb2f680d01109d4 (patch)
tree7a86ea47b7dadfca22ecfa7a76c4189c73ec5f8f
downloadaur-18e5e3314d2406e33aed5bbbffb2f680d01109d4.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
-rw-r--r--ccrtp.install22
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63dfd06603bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ccrtp
+ pkgdesc = An implementation of RTP, the real-time transport protocol from the IETF
+ pkgver = 2.1.2
+ pkgrel = 1
+ url = http://www.gnu.org/software/ccrtp/
+ install = ccrtp.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom
+ depends = ucommon
+ depends = libgcrypt
+ source = http://dev.gnutelephony.org/dist/tarballs/ccrtp-2.1.2.tar.gz
+ source = http://dev.gnutelephony.org/dist/tarballs/ccrtp-2.1.2.tar.gz.sig
+ md5sums = e6792cbd8b705901c205a509bd7f812f
+ md5sums = SKIP
+
+pkgname = ccrtp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd88bc7c468f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Jeff Mickey <jeff@archlinux.org>
+# Contributor: John Proctor <jproctor@prium.net>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+
+pkgname=ccrtp
+pkgver=2.1.2
+pkgrel=1
+pkgdesc="An implementation of RTP, the real-time transport protocol from the IETF"
+arch=('i686' 'x86_64')
+url="http://www.gnu.org/software/ccrtp/"
+license=('GPL' 'custom')
+depends=('ucommon' 'libgcrypt')
+install=$pkgname.install
+source=("http://dev.gnutelephony.org/dist/tarballs/$pkgname-$pkgver.tar.gz"{,.sig})
+md5sums=('e6792cbd8b705901c205a509bd7f812f'
+ 'SKIP')
+validpgpkeys=('3D937C85BF4A787DF6C7247DFC531209EA8888AD')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 COPYING.addendum "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/ccrtp.install b/ccrtp.install
new file mode 100644
index 000000000000..51b971c5c35b
--- /dev/null
+++ b/ccrtp.install
@@ -0,0 +1,22 @@
+infodir=usr/share/info
+filelist=(ccrtp.info)
+
+post_install() {
+ [[ -x usr/bin/install-info ]] || return 0
+ for file in "${filelist[@]}"; do
+ install-info "$infodir/$file.gz" "$infodir/dir" 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ [[ -x usr/bin/install-info ]] || return 0
+ for file in "${filelist[@]}"; do
+ install-info --delete "$infodir/$file.gz" "$infodir/dir" 2> /dev/null
+ done
+}
+
+# vim:set ts=2 sw=2 et: