summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-06 14:37:45 +0100
committerBartłomiej Piotrowski2018-01-06 14:37:45 +0100
commitfa783821a88597f0c0b27c4072e483f35a86aaa6 (patch)
tree955c268bfe1c6a58792b7f860f09ac802ac26f93
downloadaur-fa783821a88597f0c0b27c4072e483f35a86aaa6.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b564951863e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ccrypt
+ pkgdesc = A command-line utility for encrypting and decrypting files and streams
+ pkgver = 1.10
+ pkgrel = 2
+ url = http://ccrypt.sourceforge.net
+ arch = x86_64
+ license = GPL2
+ depends = glibc
+ source = http://downloads.sourceforge.net/ccrypt/ccrypt-1.10.tar.gz
+ sha1sums = 95d4e524abb146946fe6af9d53ed0e5e294b34e2
+
+pkgname = ccrypt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..286340c24cc3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Maintainer: Thorsten Töpper <atsutane-tu@freethoughts.de>
+
+pkgname=ccrypt
+pkgver=1.10
+pkgrel=2
+pkgdesc='A command-line utility for encrypting and decrypting files and streams'
+arch=('x86_64')
+url="http://ccrypt.sourceforge.net"
+license=('GPL2')
+depends=('glibc')
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('95d4e524abb146946fe6af9d53ed0e5e294b34e2')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}/" install
+}
+
+# vim:set ts=2 sw=2 et: