summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGábor Dobra2016-12-02 02:37:24 +0100
committerGábor Dobra2016-12-02 02:48:00 +0100
commit3813ece187216aacc7172119572e7c9391660651 (patch)
tree59edecd65562e4bb2542c994f5782f61bfeb1481
downloadaur-3813ece187216aacc7172119572e7c9391660651.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a05bc2097a11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ccsh-shell-git
+ pkgdesc = C++ shell
+ pkgver = r83.d0f0cf5
+ pkgrel = 1
+ url = https://github.com/cpp-ftw/ccsh
+ arch = any
+ groups = ccsh-git
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = make
+ depends = boost
+ depends = ccsh-lib-git
+ depends = cling-git
+ source = git+https://github.com/cpp-ftw/ccsh.git
+ md5sums = SKIP
+
+pkgname = ccsh-shell-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62b0db0304aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: dobragab <dobragab@gmail.com>
+
+pkgname=('ccsh-shell-git')
+pkgver=r83.d0f0cf5
+pkgrel=1
+pkgdesc='C++ shell'
+arch=('any')
+url='https://github.com/cpp-ftw/ccsh'
+license=('GPL3')
+depends=('boost' 'ccsh-lib-git' 'cling-git')
+makedepends=('git' 'cmake' 'make')
+source=("git+https://github.com/cpp-ftw/ccsh.git")
+md5sums=(SKIP)
+
+pkgver() {
+ cd "ccsh"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "ccsh"
+
+ cmake . -DWITH_LIB=OFF -DWITH_TEST=OFF -DWITH_CLING=ON
+ make
+
+ install -Dm755 "$srcdir/ccsh/ccsh" "$pkgdir/usr/bin/ccsh"
+ install -Dm644 "$srcdir/ccsh/ui/clingrc.hpp" "$pkgdir/etc/ccsh/clingrc.hpp"
+}
+