summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-06 14:38:21 +0100
committerBartłomiej Piotrowski2018-01-06 14:38:21 +0100
commitcbb95f335489031b90f2241743b086dcb716b7ae (patch)
tree3c6d353c3fbc28110387fcdd2295bd13759c0e99
downloadaur-cbb95f335489031b90f2241743b086dcb716b7ae.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD43
-rw-r--r--cdcd-0.6.6-x86_64.patch11
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93a2e8e70286
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cdcd
+ pkgdesc = A commandline cd-player
+ pkgver = 0.6.6
+ pkgrel = 9
+ url = http://libcdaudio.sourceforge.net/
+ arch = x86_64
+ license = GPL2
+ depends = libcdaudio
+ depends = readline
+ source = http://downloads.sourceforge.net/libcdaudio/cdcd-0.6.6.tar.gz
+ source = cdcd-0.6.6-x86_64.patch
+ md5sums = dc17f2e275c7214cb693f6abb50f29fb
+ md5sums = 7c39f01408fc084e2c62da4da324370e
+
+pkgname = cdcd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..773c967994ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Federico Cinelli <cinelli@aur.archlinux.org>
+# Contributor dorphell <dorphell@archlinux.org>
+# Contributor Sarah Hay <sarahhay@mb.sympatico.ca>
+
+pkgname=cdcd
+pkgver=0.6.6
+pkgrel=9
+pkgdesc="A commandline cd-player"
+arch=('x86_64')
+depends=('libcdaudio' 'readline')
+url="http://libcdaudio.sourceforge.net/"
+license=('GPL2')
+source=("http://downloads.sourceforge.net/libcdaudio/$pkgname-$pkgver.tar.gz"
+ "cdcd-0.6.6-x86_64.patch")
+md5sums=('dc17f2e275c7214cb693f6abb50f29fb'
+ '7c39f01408fc084e2c62da4da324370e')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ if [[ "$CARCH" == "x86_64" ]]; then
+ patch -Np1 -i "$srcdir/cdcd-0.6.6-$CARCH.patch"
+ fi
+
+
+ sed -i 's/(CPPFunction \*)/(rl_completion_func_t \*)/' cmd_cdcd.c
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+
+ mv "$pkgdir/usr/info" "$pkgdir/usr/share/"
+ mv "$pkgdir/usr/man/" "$pkgdir/usr/share/"
+ rm "$pkgdir/usr/share/dir"
+
+ install -dm755 "$pkgdir/usr/bin" "$pkgdir/usr/share"
+}
diff --git a/cdcd-0.6.6-x86_64.patch b/cdcd-0.6.6-x86_64.patch
new file mode 100644
index 000000000000..25d122435881
--- /dev/null
+++ b/cdcd-0.6.6-x86_64.patch
@@ -0,0 +1,11 @@
+--- a/config.sub 2009-09-15 00:42:36.000000000 -0700
++++ b/config.sub 2009-09-15 00:42:36.000000000 -0700
+@@ -155,7 +155,7 @@
+ | alpha | we32k | ns16k | clipper | i370 | sh \
+ | powerpc | powerpcle | 1750a | dsp16xx | mips64 | mipsel \
+ | pdp11 | mips64el | mips64orion | mips64orionel \
+- | sparc | sparclet | sparclite | sparc64)
++ | sparc | sparclet | sparclite | sparc64 | x86_64-*)
+ basic_machine=$basic_machine-unknown
+ ;;
+ # We use `pc' rather than `unknown'