summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDouglas McFadzean2015-09-05 18:58:22 +0100
committerDouglas McFadzean2015-09-05 18:58:22 +0100
commit874793d9448c82ce53f21a6b92ef3cd133589eeb (patch)
treebd0370c81b3696a223551359253e685c597780d5
downloadaur-874793d9448c82ce53f21a6b92ef3cd133589eeb.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d2fd300ef7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cdck-bin
+ pkgdesc = Command-line tool for verifying the quality of a written CD or DVD
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = http://swaj.net/unix/index.html#cdck
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = glibc
+ depends = gcc-libs
+ optdepends = gnuplot
+ source = http://ftp.debian.org/debian/pool/main/c/cdck/cdck_0.7.0+dfsg-1_i386.deb
+ md5sums = 21c8eacaf17f5994e6567225f4e570ea
+
+pkgname = cdck-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43b02bebed0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: ninian <mcfadzean.org.uk ta linux>
+
+pkgname=cdck-bin
+_debname=${pkgname%-bin}
+_debrepo='http://ftp.debian.org/debian/pool/main/c/'
+_debrel='+dfsg-1'
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Command-line tool for verifying the quality of a written CD or DVD"
+arch=('i686' 'x86_64')
+url="http://swaj.net/unix/index.html#cdck"
+license=('GPL2')
+depends=('glibc' 'gcc-libs')
+optdepends=('gnuplot')
+if [[ $CARCH == 'x86_64' ]]; then
+ _debarch=amd64
+ md5sums=('304aab6393370cfd4304958846c258a0')
+else
+ _debarch=i386
+ md5sums=('21c8eacaf17f5994e6567225f4e570ea')
+fi
+source=("${_debrepo}${_debname}/${_debname}_${pkgver}${_debrel}_${_debarch}.deb")
+
+package() {
+ cd "$srcdir"
+ ar x "${_debname}_${pkgver}${_debrel}_${_debarch}.deb"
+ tar xf data.tar.xz -C "$pkgdir/"
+}
+