summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-07-06 09:34:43 +0200
committeraksr2015-07-06 09:34:43 +0200
commitfd92158a6feaceebb2660bd649c7c2454e20b1ea (patch)
tree84a28e54ad8673f21e698283f080a4ce20440905
downloadaur-fd92158a6feaceebb2660bd649c7c2454e20b1ea.tar.gz
Start.
-rw-r--r--.SRCINFO28
-rw-r--r--FILE6
-rw-r--r--PKGBUILD47
-rw-r--r--fix-getline.patch30
-rw-r--r--getopt.patch11
-rw-r--r--makefile.patch20
6 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a1c5bb98fc6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = cdecl
+ pkgdesc = Translation between C declarations and pseudo-English
+ pkgver = 2.5
+ pkgrel = 3
+ url = http://www.ibiblio.org/pub/linux/devel/lang/c/
+ arch = i686
+ arch = x86_64
+ license = Public Domain
+ depends = readline
+ source = http://www.ibiblio.org/pub/linux/devel/lang/c/cdecl-2.5.tar.gz
+ source = getopt.patch
+ source = makefile.patch
+ source = fix-getline.patch
+ md5sums = 29895dab52e85b2474a59449e07b7996
+ md5sums = bd0889f5c6142b46f667700ebf0eda02
+ md5sums = 3a2a766cdc3fdc714ba35655d4d836a9
+ md5sums = df27d358e2e603609adf3e6165b74afe
+ sha1sums = b955a0b95b635090360b19de888cb29d5c005296
+ sha1sums = 1d2dfca8664d5f510fbd63bf35cb35bbe448778d
+ sha1sums = 3fbb41c890813e80ddc11d95dff0a00cbfc5a3f8
+ sha1sums = 2b046c946dbeab168e26d0f5a99bbb12afe3fe27
+ sha256sums = b74caef08407a2195d6f1facf103e5af29253f67d599486164241b14ee42a936
+ sha256sums = e81af13a029c27b6c38a2041b15b1e2f236286361bddbb367034eb7b48186cd0
+ sha256sums = f61a2e1387479c408a3af9897de514e4a420409677ff3a234fd403ad0a607d2a
+ sha256sums = f8676cfff24ddff71d5d7f737d7a6612573c28d63d99385697812af6352312db
+
+pkgname = cdecl
+
diff --git a/FILE b/FILE
new file mode 100644
index 000000000000..164b1c8e91b6
--- /dev/null
+++ b/FILE
@@ -0,0 +1,6 @@
+# Netscape HTTP Cookie File
+# http://curl.haxx.se/docs/http-cookies.html
+# This file was generated by libcurl! Edit at your own risk.
+
+#HttpOnly_aur.archlinux.org FALSE / TRUE 1424642328 AURSID 9fd1300f226354efa28a15b0af8b401d
+aur.archlinux.org FALSE / FALSE 1424642305 AURLANG en
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53ace4cf217b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Contributor: Nicolas Martyanoff <khaelin@gmail.com>
+# Contributor: Chris Brannon <cmbrannon79@gmail.com>
+# Contributor: Chris Brannon <cmbrannon79@gmail.com>
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=cdecl
+pkgver=2.5
+pkgrel=3
+pkgdesc="Translation between C declarations and pseudo-English"
+arch=('i686' 'x86_64')
+url="http://www.ibiblio.org/pub/linux/devel/lang/c/"
+license=('Public Domain')
+depends=('readline')
+source=("http://www.ibiblio.org/pub/linux/devel/lang/c/$pkgname-$pkgver.tar.gz"
+ 'getopt.patch'
+ 'makefile.patch'
+ 'fix-getline.patch')
+md5sums=('29895dab52e85b2474a59449e07b7996'
+ 'bd0889f5c6142b46f667700ebf0eda02'
+ '3a2a766cdc3fdc714ba35655d4d836a9'
+ 'df27d358e2e603609adf3e6165b74afe')
+sha1sums=('b955a0b95b635090360b19de888cb29d5c005296'
+ '1d2dfca8664d5f510fbd63bf35cb35bbe448778d'
+ '3fbb41c890813e80ddc11d95dff0a00cbfc5a3f8'
+ '2b046c946dbeab168e26d0f5a99bbb12afe3fe27')
+sha256sums=('b74caef08407a2195d6f1facf103e5af29253f67d599486164241b14ee42a936'
+ 'e81af13a029c27b6c38a2041b15b1e2f236286361bddbb367034eb7b48186cd0'
+ 'f61a2e1387479c408a3af9897de514e4a420409677ff3a234fd403ad0a607d2a'
+ 'f8676cfff24ddff71d5d7f737d7a6612573c28d63d99385697812af6352312db')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -Np1 -i "$srcdir/getopt.patch"
+ patch -Np1 -i "$srcdir/makefile.patch"
+ patch -Np1 -i "$srcdir/fix-getline.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir -p $pkgdir/usr/{bin,share/man/man1}
+ make PREFIX="$pkgdir/usr" install
+}
+
diff --git a/fix-getline.patch b/fix-getline.patch
new file mode 100644
index 000000000000..1fc3c047575c
--- /dev/null
+++ b/fix-getline.patch
@@ -0,0 +1,30 @@
+diff -Naur cdecl-2.5/cdecl.c cdecl-2.5-new/cdecl.c
+--- cdecl-2.5/cdecl.c 1996-01-15 21:54:46.000000000 -0600
++++ cdecl-2.5-new/cdecl.c 2010-09-04 03:12:43.000000000 -0500
+@@ -90,7 +90,7 @@
+ #ifdef USE_READLINE
+ # include <readline/readline.h>
+ /* prototypes for functions related to readline() */
+- char * getline();
++ char * our_getline(void);
+ char ** attempt_completion(char *, int, int);
+ char * keyword_completion(char *, int);
+ char * command_completion(char *, int);
+@@ -375,7 +375,7 @@
+ static char *line_read = NULL;
+
+ /* Read a string, and return a pointer to it. Returns NULL on EOF. */
+-char * getline ()
++char * our_getline (void)
+ {
+ /* If the buffer has already been allocated, return the memory
+ to the free pool. */
+@@ -887,7 +887,7 @@
+
+ if (!quiet) (void) printf("Type `help' or `?' for help\n");
+ ret = 0;
+- while ((line = getline())) {
++ while ((line = our_getline())) {
+ if (!strcmp(line, "quit") || !strcmp(line, "exit")) {
+ free(line);
+ return ret;
diff --git a/getopt.patch b/getopt.patch
new file mode 100644
index 000000000000..4f6f5467a30b
--- /dev/null
+++ b/getopt.patch
@@ -0,0 +1,11 @@
+diff -ru cdecl-2.5_orig/cdecl.c cdecl-2.5/cdecl.c
+--- cdecl-2.5_orig/cdecl.c 2008-07-02 11:36:14.854458119 +0200
++++ cdecl-2.5/cdecl.c 2008-07-02 11:36:59.101943479 +0200
+@@ -124,7 +124,6 @@
+
+ #if __STDC__
+ char *ds(char *), *cat(char *, ...), *visible(int);
+- int getopt(int,char **,char *);
+ int main(int, char **);
+ int yywrap(void);
+ int dostdin(void);
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..6728cf7a9bb8
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,20 @@
+diff -Naur cdecl-2.5_orig/Makefile cdecl-2.5/Makefile
+--- cdecl-2.5_orig/Makefile 1996-01-15 23:36:38.000000000 -0600
++++ cdecl-2.5/Makefile 2010-09-04 03:18:43.000000000 -0500
+@@ -17,11 +17,12 @@
+
+ CFLAGS= -s -O2 -DUSE_READLINE
+ CC= gcc
+-LIBS= -lreadline -ltermcap
++LIBS= -lreadline
+ ALLFILES= makefile cdgram.y cdlex.l cdecl.c cdecl.1 testset testset++
+-BINDIR= /usr/bin
+-MANDIR= /usr/man/man1
+-CATDIR= /usr/man/cat1
++PREFIX=/usr/local
++BINDIR= $(PREFIX)/bin
++MANDIR= $(PREFIX)/share/man/man1
++CATDIR= $(PREFIX)/share/man/cat1
+ INSTALL= install -c
+ INSTALL_DATA= install -c -m 644
+