summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorautinerd2022-06-16 09:31:42 +0200
committerautinerd2022-06-16 09:31:42 +0200
commit17e7c367225dbc1c8efe7934e7c6cbcff44ca131 (patch)
tree788b3e058e4db6e7c8f74f2fa27353107fbc3d71
parentc931fae755da307752a0319f66dcd0025d4d9788 (diff)
downloadaur-17e7c367225dbc1c8efe7934e7c6cbcff44ca131.tar.gz
fix version number for git
uses mksh instead of ksh as dependency
-rw-r--r--PKGBUILD36
1 files changed, 23 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 48c4274e29c4..3b4fc5e27a28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_gitname=cdesktopenv
pkgname="$_gitname"-git
-pkgver=2.4.0
+pkgver=2.4.0.778.g2a988df4c
pkgrel=1
pkgdesc="Common Desktop Environment"
url="http://sourceforge.net/projects/cdesktopenv/"
@@ -13,7 +13,7 @@ arch=('i686' 'x86_64') # Some parts of CDE are not stable on x86_64 yet.
license=('LGPL2')
options=(!strip !zipman)
install="cdesktopenv.install"
-depends=(openmotif xbitmaps rpcbind ksh ncurses libxss xbitmaps libxinerama libutempter rpcsvc-proto xorg-mkfontdir xorg-bdftopcf xorg-xrdb libxpm libxaw)
+depends=(openmotif xbitmaps rpcbind mksh ncurses libxss xbitmaps libxinerama libutempter rpcsvc-proto xorg-mkfontdir xorg-bdftopcf xorg-xrdb libxpm libxaw)
makedepends=(tcl ncompress bison)
optdepends=('xorg-fonts-100dpi: additional fonts'
'cups: for printing support'
@@ -26,27 +26,37 @@ source=("git+https://git.code.sf.net/p/cdesktopenv/code"
'fonts.alias'
'fonts.dir'
'startxsession.sh'
- 'cde.desktop')
+ 'cde.desktop'
+ 'mksh.patch'
+ 'fonts_alias.patch')
-md5sums=('SKIP'
- 'ba7fcfcfa2996be6d87b5a90dd94fd7b'
- '18f9ef4643ff7ed6637907f5cbdabecf'
- '5cc80c2851ea90b94e94b0c5d92d81fb'
- '897316929176464ebc9ad085f31e7284'
- '2e5557241915e4c2761ba136dbcba469'
- '7d11b9d2bc1234278f14151025744916')
+sha512sums=('SKIP'
+ '1964e5150fa7e29905f19651834ff7c609a69a1a652b30350bb6c6f89aa282fd7b3057f4a025c8dabb3f0b5c98a2afe512e2a77a78893e9a935d5987bd954545'
+ 'a14176bc2b9e7cc163965fe1c53e12b3bee7e2ca47e91ec9508666f6a91576ae658ff009cf4f2c22dd06d98e3b098c90f5019896a6fa7fde6cf9810a805798a8'
+ '69b740e1d8925f0dd2df09a206e3c36c1331af1617085610689067d1042a031b442fdeff502a36a895265abb4c1f899fa6ed2df6c60df8a60f8835e037c10067'
+ 'a546d1300f49037a465ecec8bc1ebd07d57015a5ff1abfa1c94da9b30576933fb68e3898ff764d4de6e6741da822a7c93adc6e845806a266a63aa14c8bb09ebb'
+ 'fdeea1adaf0de5da63e3cc8760893451e7ad1b2bb5c383f70208e3ac62e8fbce3092d6036e70ac46d4ccfb0a4884029cbf0088e58e56004bc9aeb7aa53983548'
+ 'bc7e4f7430c6d939459faa97aac1f43c87c08828f751933b6f9247040e3eec8ea0194260b020e90e71ccb4d51198d403e7687155a87d3e9fb409a233bd768881'
+ '4821925f902481bf59cda0f7a51b35c834c80f676e37608030e7cd64b1e18269cd7cbe1f37cffedd0f1205a6621f51c1b22293c959cffa3602bfdcdba82fd8f4'
+ 'c7f34130a7d4881584bdf7592a218c8eb18f017e05e87b27020a170858fc5040e73806fcb2ad6fa37abc7114a431fc143400f79831a57aab35bac083e5158520')
pkgver() {
cd "$srcdir/code/cde"
- git describe --long | sed 's/\([0-9]\.[0-9]\.[0-9]\).*/\1/'
+ git describe --long --tags | sed 's/-/./g'
+}
+
+prepare() {
+ # Sets autoconf to accept mksh, which is much easier to build then the original ksh93
+ patch -p1 -i mksh.patch
+ # Bug in build where it tries to find a file in the /usr directory
+ patch -p1 -i fonts_alias.patch
}
build() {
cd "$srcdir/code/cde"
-
./autogen.sh
./configure --with-gnu-ld --prefix=/usr/dt
- make
+ make LDFLAGS=-lm
}