summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2023-06-19 13:51:26 +1000
committerMark Blakeney2023-06-19 13:51:26 +1000
commitcc07ccf0c187a5eb31dd9ec91837d3e91922bd56 (patch)
tree78e47bd809a09f1e144e2c09f0ac5734fe6b15e2
parent263fab43687b7a8a42817af8493808df59d4ec5e (diff)
downloadaur-cc07ccf0c187a5eb31dd9ec91837d3e91922bd56.tar.gz
Update to 3.7
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9bc688f070f..5b6fb34b248d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cdhist
pkgdesc = Linux shell cd history
- pkgver = 3.6
+ pkgver = 3.7
pkgrel = 1
url = https://github.com/bulletmark/cdhist
install = install.sh
@@ -10,8 +10,9 @@ pkgbase = cdhist
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
+ makedepends = python-setuptools-scm
depends = python>=3.7
- source = cdhist-3.6.tar.gz::https://github.com/bulletmark/cdhist/archive/3.6.tar.gz
- sha1sums = 386bee11faffabdcc49dfd27b49fc341d518612a
+ source = cdhist-3.7.tar.gz::https://github.com/bulletmark/cdhist/archive/3.7.tar.gz
+ sha1sums = d277f164495f260eca99e67fb61ea2c19bc05f43
pkgname = cdhist
diff --git a/PKGBUILD b/PKGBUILD
index d780814707fd..b9ea83ef9258 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=cdhist
-pkgver=3.6
+pkgver=3.7
pkgrel=1
pkgdesc="Linux shell cd history"
url="https://github.com/bulletmark/$pkgname"
license=(GPL3)
arch=(any)
depends=("python>=3.7")
-makedepends=(python-setuptools python-build python-installer python-wheel)
-install=install.sh
+makedepends=(python-setuptools python-build python-installer
+ python-wheel python-setuptools-scm)
+install="install.sh"
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha1sums=('386bee11faffabdcc49dfd27b49fc341d518612a')
+sha1sums=('d277f164495f260eca99e67fb61ea2c19bc05f43')
build() {
cd "$srcdir/$pkgname-$pkgver"
- python -m build --wheel --no-isolation
+ SETUPTOOLS_SCM_PRETEND_VERSION="$pkgver" python -m build --wheel --no-isolation
}
package() {