summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRalf Mueller2017-05-24 16:42:52 +0200
committerRalf Mueller2017-05-24 16:42:52 +0200
commit114d2d3ee840907ce979714031c4d2117e27e8e7 (patch)
tree35528fcf8751c84f15e9daed062881489e7fabbc
parentdec1b05504b101a29c44763ae145f4ad24bea4f4 (diff)
downloadaur-114d2d3ee840907ce979714031c4d2117e27e8e7.tar.gz
update for release cdi-1.8.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f8c0f606c5e..4d718c361898 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = cdi
pkgdesc = CDI is a general purpose C-library for file IO in the geoscience area. Supported data formats are GRIB, netCDF, SERVICE, EXTRA and IEG. CDI is the IO part of CDO
- pkgver = 1.8.0
+ pkgver = 1.8.1
pkgrel = 0
url = https://code.zmaw.de/projects/cdi
arch = i686
arch = x86_64
license = GPLv2
makedepends = netcdf
- makedepends = grib_api
+ makedepends = eccodes
makedepends = libaec
depends = netcdf
- depends = grib_api
+ depends = eccodes
depends = libaec
- source = https://code.zmaw.de/attachments/download/13770/cdi-1.8.0.tar.gz
- md5sums = 6655ba13cfc285b5aa260de2eac7fd5a
+ source = https://code.zmaw.de/attachments/download/14290/cdi-1.8.1.tar.gz
+ md5sums = e06c6643f9c042c2b1f1ea8ed7ce8d7d
pkgname = cdi
diff --git a/PKGBUILD b/PKGBUILD
index 8f5ede18e9b5..169754e4574c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkg=cdi
flavour=
pkgname=${pkg}${flavour}
-pkgver=1.8.0
-fileID=13770
+pkgver=1.8.1
+fileID=14290
pkgrel=0
pkgdesc="CDI is a general purpose C-library for file IO in the geoscience area. Supported data formats are GRIB, netCDF, SERVICE, EXTRA and IEG. CDI is the IO part of CDO"
url="https://code.zmaw.de/projects/cdi"
license=('GPLv2')
-depends=('netcdf' 'grib_api' 'libaec')
-makedepends=('netcdf' 'grib_api' 'libaec')
+depends=('netcdf' 'eccodes' 'libaec')
+makedepends=('netcdf' 'eccodes' 'libaec')
provides=()
conflicts=()
replaces=()
@@ -17,11 +17,11 @@ arch=(i686 x86_64)
backup=()
install=
source=(https://code.zmaw.de/attachments/download/${fileID}/${pkg}-${pkgver}.tar.gz)
-md5sums=('6655ba13cfc285b5aa260de2eac7fd5a')
+md5sums=('e06c6643f9c042c2b1f1ea8ed7ce8d7d')
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --with-netcdf=/usr --with-grib_api=/usr --with-szlib CFLAGS='-O2 -fopenmp' LIBS='-lpng -lopenjpeg'
+ ./configure --prefix=/usr --with-netcdf=/usr --with-grib_api=/usr --with-szlib CFLAGS='-O2 -fopenmp' LDFLAGS='-leccodes' LIBS='-lpng -lopenjpeg'
make -j12 || return 1
}
package() {