summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Schmiade2015-06-13 13:40:20 +0200
committerTimo Schmiade2015-06-13 13:40:20 +0200
commit9e6f79d138252a1ef81af44246636f89abdc0563 (patch)
tree162aedaae31159b9dbfc95ff097a76a88f763c3b
downloadaur-9e6f79d138252a1ef81af44246636f89abdc0563.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5058cdca613a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cdrip
+ pkgdesc = A cdparanoia, lame and musicbrainz.org frontend written in python.
+ pkgver = 2.2
+ pkgrel = 4
+ url = https://github.com/the-isz/cdrip
+ arch = any
+ license = GPL
+ depends = python2
+ depends = python2-musicbrainz2
+ depends = python2-eyed3
+ depends = libdiscid
+ depends = cdparanoia
+ options = !emptydirs
+ source = https://github.com/the-isz/cdrip/tarball/2.2
+ md5sums = 0e713c7c86454e4a5d22e9421f17c238
+
+pkgname = cdrip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a3187cb021f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: Timo Schmiade <the_isz@gmx.de>
+
+pkgname=cdrip
+pkgver=2.2
+pkgrel=4
+pkgdesc="A cdparanoia, lame and musicbrainz.org frontend written in python."
+arch=("any")
+url="https://github.com/the-isz/cdrip"
+license=("GPL")
+depends=("python2" "python2-musicbrainz2" "python2-eyed3" "libdiscid" "cdparanoia")
+options=(!emptydirs)
+source=("https://github.com/the-isz/$pkgname/tarball/$pkgver")
+md5sums=("0e713c7c86454e4a5d22e9421f17c238")
+
+package() {
+ cd "$srcdir/the-isz-$pkgname-ae81c46/deployment"
+
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ mv "$pkgdir/usr/bin/cdrip.py" "$pkgdir/usr/bin/cdrip"
+}