summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormasutu2015-06-24 00:23:41 +0200
committermasutu2015-06-24 00:23:41 +0200
commit54cfdbebd8738f94235ea68546bd42e9e88ec9b6 (patch)
tree3d2dddf4287d634713511b8659ff8aaa72b2404b
downloadaur-54cfdbebd8738f94235ea68546bd42e9e88ec9b6.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
-rw-r--r--cdu.install9
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d341cce3764c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = cdu
+ pkgdesc = du like command but display a pretty histogram with optional colors
+ pkgver = 0.37
+ pkgrel = 1
+ url = http://arsunik.free.fr/prog/cdu.html
+ install = cdu.install
+ arch = any
+ license = GPL
+ depends = perl
+ source = http://arsunik.free.fr/pkg/cdu-0.37.tar.gz
+ md5sums = 625e8e62c00552e3fe054ac0af8392c0
+
+pkgname = cdu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e858649f175
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: masutu <masutu dot arch at gmail dot com>
+# Contributor: Igor Hlina <srigi (at) srigi (dot) sk>
+pkgname=cdu
+pkgver=0.37
+pkgrel=1
+pkgdesc="du like command but display a pretty histogram with optional colors"
+arch=('any')
+url="http://arsunik.free.fr/prog/cdu.html"
+license=('GPL')
+depends=('perl')
+source=(http://arsunik.free.fr/pkg/$pkgname-$pkgver.tar.gz)
+md5sums=('625e8e62c00552e3fe054ac0af8392c0')
+install=${pkgname}.install
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -D -m755 cdu $pkgdir/usr/bin/cdu
+ install -D -m644 cdu.1 $pkgdir/usr/share/man/man1/cdu.1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/cdu.install b/cdu.install
new file mode 100644
index 000000000000..a34abf2ccbe2
--- /dev/null
+++ b/cdu.install
@@ -0,0 +1,9 @@
+post_install() {
+ /bin/cat << EOF
+
+For better comfort, you can define alias in your ~/.bashrc file.
+
+ alias du='cdu -idh'
+
+EOF
+}