summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEpix2022-01-23 18:38:02 -0600
committerEpix2022-01-23 18:38:02 -0600
commit1eb5ed6933abd2d0abda010b8ef2e4b7edbd278e (patch)
treeb9694e761799a1f4262dc53324ac79764e7bacfb
parentd05d63eb8c5bd526f76ef7e363685d1806fa01a8 (diff)
downloadaur-1eb5ed6933abd2d0abda010b8ef2e4b7edbd278e.tar.gz
Update to 9.2.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b88027814d0b..1a08db80c844 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = ce-toolchain
pkgdesc = Toolchain and libraries for C/C++ programming on the TI-84+ CE calculator series
- pkgver = 9.1
+ pkgver = 9.2.2
pkgrel = 1
url = https://ce-programming.github.io/toolchain/index.html
arch = i686
arch = x86_64
license = LGPL3
- source = https://github.com/CE-Programming/toolchain/releases/download/v9.1/linux_CEdev.zip
- sha256sums = 338e48b25369bd09167a77f70493c7b6acaa63b109aae6cd1f07c72f0708c757
+ source = https://github.com/CE-Programming/toolchain/releases/download/v9.2.2/linux_CEdev_v9.2.2.tar.gz
+ sha256sums = 7d5ce9b5200677357ce1b351fb4c3ba5aa6944d42745b3c504a38bf99db9a17b
pkgname = ce-toolchain
diff --git a/PKGBUILD b/PKGBUILD
index efcc411f2f41..f150814c4604 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Epix <epixtm@protonmail.com>
pkgname=ce-toolchain
-pkgver=9.1
+pkgver=9.2.2
pkgrel=1
pkgdesc="Toolchain and libraries for C/C++ programming on the TI-84+ CE calculator series"
arch=('i686' 'x86_64')
url="https://ce-programming.github.io/toolchain/index.html"
license=('LGPL3')
-source=("https://github.com/CE-Programming/toolchain/releases/download/v${pkgver}/linux_CEdev.zip")
-sha256sums=('338e48b25369bd09167a77f70493c7b6acaa63b109aae6cd1f07c72f0708c757')
+source=("https://github.com/CE-Programming/toolchain/releases/download/v${pkgver}/linux_CEdev_v${pkgver}.tar.gz")
+sha256sums=('7d5ce9b5200677357ce1b351fb4c3ba5aa6944d42745b3c504a38bf99db9a17b')
package() {
- cd "$srcdir"
- rm linux_CEdev.zip
+ cd "$srcdir/CEdev"
install -d "${pkgdir}/opt/${pkgname}"
cp -a . "${pkgdir}/opt/${pkgname}"
- chmod -R 755 "${pkgdir}/opt/${pkgname}/bin"
+ chmod -R 755 "${pkgdir}/opt/${pkgname}"
# profile addenums
install -d "${pkgdir}/etc/profile.d"
echo -e "export CEDEV=/opt/${pkgname}\nexport PATH=\$PATH:/opt/${pkgname}/bin" > "${pkgdir}/etc/profile.d/${pkgname}.sh"
-} \ No newline at end of file
+}