summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErfaun Atabakhsh2023-04-09 16:22:38 -0500
committerErfaun Atabakhsh2023-04-09 16:22:38 -0500
commit749c7cdfc7e2b53debc1f6872f9c2c3dfc117d35 (patch)
treee3cda25b0158dafc0c4356dc54df27b88b434341
parent230765280a620584102b70e1facde9ac06be74cd (diff)
downloadaur-749c7cdfc7e2b53debc1f6872f9c2c3dfc117d35.tar.gz
Update PKGBUILD for conflicts and replace, add install file
-rw-r--r--PKGBUILD7
-rw-r--r--ce-toolchain-bin.install7
2 files changed, 12 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fbb833cacc85..407616481747 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,20 @@
pkgbase=ce-toolchain
pkgname=ce-toolchain-bin
pkgver=11.0
-pkgrel=1
+pkgrel=2
pkgdesc="Toolchain and libraries for C/C++ programming on the TI-84+ CE calculator series"
+install=$pkgname.install
depends=("glibc" "zlib" "gcc-libs")
options=("!strip" "!staticlibs")
+provides=("ce-toolchain")
+conflicts=("ce-toolchain")
arch=('i686' 'x86_64')
url="https://ce-programming.github.io/toolchain/index.html"
license=('LGPL3')
source=("https://github.com/CE-Programming/toolchain/releases/download/v${pkgver}/CEdev-Linux.tar.gz")
sha256sums=('db7eee28fc26daa3d60b0b426bcd4d70b573ba705117f8514e4c5d39ee26a105')
-package() {
+package_ce-toolchain-bin() {
cd "$srcdir/CEdev"
install -d "${pkgdir}/opt/${pkgname}"
diff --git a/ce-toolchain-bin.install b/ce-toolchain-bin.install
new file mode 100644
index 000000000000..52c168d14d90
--- /dev/null
+++ b/ce-toolchain-bin.install
@@ -0,0 +1,7 @@
+post_install() {
+cat << EOF
+=============================================================================
+Restart your computer to have the ce-toolchain binaries show up in your \$PATH
+=============================================================================
+EOF
+}