summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEpix2021-09-10 00:16:02 -0500
committerEpix2021-09-10 00:17:35 -0500
commitd05d63eb8c5bd526f76ef7e363685d1806fa01a8 (patch)
treec4268cbf1ec1670df5893f72f4e033be05fea46c
downloadaur-d05d63eb8c5bd526f76ef7e363685d1806fa01a8.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b88027814d0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = ce-toolchain
+ pkgdesc = Toolchain and libraries for C/C++ programming on the TI-84+ CE calculator series
+ pkgver = 9.1
+ pkgrel = 1
+ url = https://ce-programming.github.io/toolchain/index.html
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ source = https://github.com/CE-Programming/toolchain/releases/download/v9.1/linux_CEdev.zip
+ sha256sums = 338e48b25369bd09167a77f70493c7b6acaa63b109aae6cd1f07c72f0708c757
+
+pkgname = ce-toolchain
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efcc411f2f41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Epix <epixtm@protonmail.com>
+pkgname=ce-toolchain
+pkgver=9.1
+pkgrel=1
+pkgdesc="Toolchain and libraries for C/C++ programming on the TI-84+ CE calculator series"
+arch=('i686' 'x86_64')
+url="https://ce-programming.github.io/toolchain/index.html"
+license=('LGPL3')
+source=("https://github.com/CE-Programming/toolchain/releases/download/v${pkgver}/linux_CEdev.zip")
+sha256sums=('338e48b25369bd09167a77f70493c7b6acaa63b109aae6cd1f07c72f0708c757')
+
+package() {
+ cd "$srcdir"
+ rm linux_CEdev.zip
+
+ install -d "${pkgdir}/opt/${pkgname}"
+ cp -a . "${pkgdir}/opt/${pkgname}"
+
+ chmod -R 755 "${pkgdir}/opt/${pkgname}/bin"
+
+ # profile addenums
+ install -d "${pkgdir}/etc/profile.d"
+ echo -e "export CEDEV=/opt/${pkgname}\nexport PATH=\$PATH:/opt/${pkgname}/bin" > "${pkgdir}/etc/profile.d/${pkgname}.sh"
+} \ No newline at end of file